About Our Calculators

Introduction

The Chemandy calculators are designed to be easy to use and follow a common theme and layout where possible. Most of them have been used for several years now and complaints about their accuracy or functionality are very rare. We do welcome these however and there is a contact link on the bottom of every page for this purpose.

Instructions for use

Simply enter the characteristics required as a decimal number and hit the "Calculate" button. Couldn't be easier! If the answer given is NaN (not a number) then it is most likely that the number was not entered as a decimal or perhaps you used a comma instead of a full stop for the decimal point.

There are two basic methods of calculation used. The simple analysis type which will only calculate ideal component values and a more comprehensive type which can also work backwards from preferred component values giving a simulation of the circuit performance.

For instance you may require a 10 dB attenuator working in a 50 Ohm system. If you use the Pi Attenuator calculator with results for resistance, attenuation, return loss, VSWR and reflection coefficient the analysis will give you an ideal series resistor of 71.151 Ohms and an ideal shunt resistor of 96.247 Ohms. Neither of these values exist and a suitable value has to be selected. This may be from components that are to hand or maybe from the list of appropriate Preferred Resistor Values. The first time that the calculate button is used, the calculated ideal resistance values will be loaded into the preferred value text boxes as a starting point. It is now possible to change the preferred values to those available and calculate again. The calculator now simulates the circuit and gives the Attenuation, Input Impedance, Reflection Coefficient, VSWR and Return Loss for the preferred values entered. This makes it possible to select the component values for a particular characteristic i.e. most accurate attenuation or the best return loss.

Microstrip Calculator Accuracy

The different formulas used for the microstrip calculators give different results. Which gives the best absolute accuracy with different PCB types has not been assessed by us and the choice is yours. The following table compares bench mark values used by Polar Instruments with the results obtained with our calculators. They are based on a 1 oz copper track, εr at 4.2 and a 0.79375 mm substrate.

Track Width (mm) | Numerical Method Zo (Ohms) | IPC-2141 JavaScript Zo (Ohms) | Wadell JavaScript Zo (Ohms) | Hartley JavaScript Zo (Ohms)
3.3 | 30.09 | 21.06 | 30.14 | 30.39
1.5 | 50.63 | 49.45 | 50.71 | 51.51
0.45 | 89.63 | 91.33 | 89.03 | 92.79

Script Language

The original calculators used VBScript to perform the calculations. This was adequate when the majority of people used Internet Explorer but now other browsers have become popular. Virtually all modern browsers have JavaScript and this has now been adopted as the standard for our new calculators. All JavaScript calculators are tested for functionality and appearance in Explorer 6.0, Mozilla Firefox 2.0.0.20 and Opera 10.10 browsers.

Send email using the Contact Us page with questions about our products or comments about this web site.


Accurate Method for Measuring Relative Dielectric Constant of a PCB Using a Vector Network Analyser analyzer and parallel plates.

Accurate Method for Measuring Relative Dielectric Constant of a PCB Using a Vector Network Analyser and parallel plates.

1) Prepare a Sample

Prepare a sample PCB which shall have a circular sample on the top and a concentric mirrored ground on the bottom. The sample shall be surrounded by at least 1 cm of bare dielectric. It may assist to put small circles at the corners of the PCB in order to define the boundaries. The sample shall have one fine hole at the centre, just large enough to insert the centre conductor of a piece of semi rigid coax. The size of the sample can be selected by using the PCB Sample Size Calculator for relative dielectric constant measurements.

2) Connect Sample

Select a short piece of semi rigid (5 cm is adequate) with a suitable connector at one end. Short the open end and then connect the semi rigid to the VNA, which should be calibrated with a sweep of about 3 GHz. Using the Smith Chart Format, perform a port extension with the VNA, which should produce a "dot" at the left hand side of a Smith Chart. Disconnect the semi rigid from the VNA and then remove the short. Make a very small countersink at the centre of the PCB sample just large enough to ensure that the semi rigid inner does not short to the bottom plane. Insert the semi rigid into the sample and solder at both sides. Reconnect to the VNA.

3) Ensure the Sample Size is Adequate

Using the Smith Chart Format on the VNA ensure that the trace starts at the right hand side (00) at the minimum frequency and sweeps clockwise. The trace should be very close to the perimeter of the chart all of the way to + 1800. If the trace does not reach + 1800, then the sweep of the VNA is inadequate or the sample size is too small.

Set the marker for exactly -900. This can be achieved on a 8753 VNA by selecting the Polar Format or Phase , setting the marker for -900 and leaving the marker at this frequency, select the Smith Chart Format again. The marker should still be at -900 point and R -j Ohms should be indicated. The -j reading shall be 49.8Ω to 50Ω for a Zo of 50Ω i.e. almost a pure reactance. If the capacitive reactance is less than this, the sample size is too large in relation to the thickness of copper.

4) Taking the reading

The VNA should indicate the capacitance at 900, but if you are using a VNA without this facility the capacitance can be calculate from the reactance and the frequency using:-

C = 1 / (2πfXc)

5) Compute the Relative Dielectric Constant

The result can be calculated using the RDC Calculator or by the following formula.

6) Wrong Size Sample

If the sample size was too large or too small, it is most likely that the data used to calculate the sample size was too far from the actual characteristics. If you suspect that this is the case, repeat the exercise using the εr that was achieved in the result above. It should be in the right ball park area!

If the thickness of the board is in doubt, then measure it with a micrometer at a point where there is no copper on either side. The measurement will need to be made very carefully with a micrometer. A vernier is not accurate enough. This is probably the most critical part of the whole process!

If the copper thickness is in doubt, then it is possible to plot a curve and find the frequency at which the capacitance value peaks, from this the copper thickness can be calculated. Refer to the RDC Article for this. Alternatively the copper size can be calculated from the thickness of the board with copper minus the thickness of the board without copper, measuring with a micrometer.

Return to Technical Articles William J Highton 25/10/2004


Building a HF amplifier in a FLEXI-BOX Part 1

Building a HF Amplifier Project

Introduction

A high frequency amplifier working across the HF bandwidth was required that has good return loss across the whole frequency band. It was decided to design an amplifier using the shunt series pair configuration and a reference to this can be found on page 872 in the excellent electronics reference book "The Art of Electronics by Paul Horowitz and Winfield Hill, Cambridge University Press, ISBN 0-521-37095-7". The circuit as shown in the book would have a relatively high input and output impedance and would not function very well in a 50 Ohm system. A termination resistor was added with a coupling capacitor at the input and an emitter follower circuit was also added followed by a resistor in the output to lower the output impedance and bring it to 50 Ohms. The resulting circuit is shown below in Figure1.

Figure 1

[Circuit diagram of HF Amplifier]

Circuit Description

The HF amplifier circuit is shown in the schematic diagram in fig 1 above. The input signal is terminated by R1 and the overall input impedance is set by R1 in parallel with R2 plus the input impedance at TR1. The gain of the TR1 stage is set by R5/R2, although R5 comes from the output of TR2, there is no voltage gain from TR2 because the output is taken from TR2 emitter. The gain of the TR2 stage is then set by the ratio of R6/R7. Finally the overall gain of 14 dB is set by R8. TR3 buffers the output of TR2 and sources 52 mA into R9||R11 which are paralleled in order to dissipate 200mW. This gives a maximum output of +11 dBm with 1 dB compression at 30 MHz. The output impedance is set by the very low emitter impedance of TR3 in series with R10. De-coupling capacitors C1, C2 and C3 are added to the + 7.5 Volt supply rail to ensure that the amplifier does not oscillate via the supply. The supply rail voltage is set low, at 7.5 Volts, in order to keep the dissipation in R9||R11 to a minimum.

Construction

The prototype circuit was built on a Transmission Line PCB, which comes with the Transmission Line FLEXI-BOX kit and is designed for the express purpose of this type of circuit development. The FLEXI-BOX is a screened project box especially designed for this sort of project. The circuit boards are available as a single item and can also be used separately from the box with SMA connectors soldered directly onto the board. The return loss of the CPWG track is normally better than -20 dB from 0.3 MHz to 3 GHz. A blank PCB is shown in Figure 2 and it can be seen that there are no ground links fitted at this stage.

Figure 2

[Photograph of blank PCB]

Grounding is decided after the PCB is fitted into the enclosure.

Technical Article Index <1 2 3> Page Number


Building a HF amplifier in a FLEXI-BOX Part 2

Figure 3 shows the PCB after the layout has been sketched on the tinned copper surface using a red felt tip pen. There is no attempt to produce intricate artwork, just the simple functional areas that are required to make the connections. At a later stage two links are added to complete the amplifier circuit.

Figure 3

[Photograph of marked PCB]

Next, the PCB is firmly clamped to the working area to ensure that the "finger count" remains constant. The outlines of the areas coloured in red are then carefully scored with a craft knife and the unwanted copper lifted with a soldering iron. After cleaning with Isopropyl Alcohol, the PCB appears as in Figure 4. The result is a bit scruffy, but for an "A" model it is adequate.

Figure 4

[Photograph of PCB with copper trimmed]

The PCB is now ready for loading with components and this is best performed before fitting the PCB into the FLEXI-BOX as in Figure 5. With so much reflective surface, it is difficult to get a clear photograph, but the black surface mount components can just be seen.

Figure 5

[Photograph of PCB with components mounted]

The two links (with red insulation) are also fitted at this stage.

Technical Article Index < 1 2 3 > Page Number


Building a HF amplifier in a FLEXI-BOX Part 3

The PCB is now fixed into the FLEXI-BOX with four corner screws.

Figure 6

[Photograph of PCB mounted in box]

Next comes the connectors and this is the beauty of this system. Whichever connector you have selected from our range BNC, SMA or N, it will easily fit direct onto the box. No drilling or taping, just fit four screws and solder the centre connector. Figure 7 shows the box with a SMA connector and a sleeve which is first slipped over the dielectric of the connector if a good high frequency response is required.

Figure 7

[Photograph of and connector with sleeve]

BNC connectors are fitted without the sleeve and most TNC connectors with a 11/16" flange will also fit directly onto the box.

Technical Article Index < 2 3 4 > Page Number


Building a HF amplifier in a FLEXI-BOX Part 4

In Figure 8, the SMA connector has been screwed onto the box and is ready for the centre connector to be soldered.

Figure 8

[Photograph of box with connector fitted]

The feed through capacitor is supplied already soldered to a small plate, and this plate is held in place with four small screws in exactly the same way as the RF connectors are fitted. The plate and two SMA connectors are shown fitted and soldered in Figure 9. The fourth hole? Well, we have not forgotten, simply fix the blanking plate with four screws, the same as for all of the connectors.

Figure 9

[Photograph of box with connector, feedthrough capacitor and blanking plate]

Next, come the lid, top and escutcheon. The escutcheon can be printed from one of the .bmp or .zip files from the Escutcheon Index, or you can generate your own on a computer with a drawing package. The type supplied by us, are printed on a very high quality paper. This gives a better appearance than a plastic version and also allows those in a hurry to simply write on an existing label. For some circuits i.e. filters, it can be very useful to print a graph of the frequency response, return loss etc.

Figure 10

[Photograph of box with top, lid and escutcheon]

Company logos can be added, manufacturers names, even clip art if it takes your fancy. The final appearance of the escutcheon is limited only by your imagination.

Technical Article Index < 3 4 5 > Page Number


Building a HF amplifier in a FLEXI-BOX Part 5

The lid and top are fitted with the four countersunk screws supplied and the end result is a small screened instrument case with a really professional finish. No more scruffy old die cast boxes, tobacco tins or secondhand enclosures.

Figure 11

[Photograph of completed box]

This article has demonstrated how easy it is to work with the FLEXI-BOX. The basic project box with the Transmission Line PCB is normally the best starting point for a small RF project.

For those that need information on soldering and de-soldering, there is an excellent collection of soldering tips at http://www.solder.net/technical/tips.asp

Technical Article Index <3 4 5> Page Number


Calculator for capacitance of a rectangular capacitor, including edge effect.

Calculator for the Capacitance of a Rectangular Parallel Plate Capacitor, Including Edge effect

The capacitance of a rectangular or square parallel plate capacitor including edge effect, can be calculated using the following formula.

[Formua for rectangular capacitor with edge effect]

Where l = Length in cm

w = Width in cm

εr= Relative Dielectric Constant

d = Dielectric thickness in cm

Enter the value of εr: |  | Capacitance without edge effect: | pF
Enter the Width: | cm |
Enter the Length: | cm | Capacitance including edge effect: | pF
Enter the thickness of the dielectric: | mm |

This calculator uses JavaScript and will function in most modern browsers. For more information see About our calculators

After a long unsuccessful search for a suitable accurate formula, I derived the formula above mainly for use when designing PCB,s and measuring Er. It assumes that there is a mirror ground plane on the bottom of the board and dielectric extending outside the edges of the (copper) plates. I have found the formula to be reasonably accurate on FR4 and it 'tracks' well to Kirchhoff's formula for a circular capacitor with an equivalent area, thickness and Er. It also appears to work fairly well on PCB tracks (using Eeff). I make no claim that this formula will work for anything other than a PCB and reserve the right to change it as and when more valid data is available to me. Hopefully this calculator will stimulate some discussion which could lead to a more accurate formula. Please use with caution and give us some feedback, good or bad.

The capacitance is also given without edge effect for comparison purposes and uses the formula.

[Formula for capacitor without edge effect]

Where l = Length in cm

w = Width in cm

εr= Relative Dielectric Constant

d = Dielectric thickness in cm

William J Highton

28/8/09

This calculator is provided free by Chemandy Electronics.

Return to Calculator Index


Calculator for Skin Effect Depth

Calculates the effective skin depth (1/ε) for common conducting materials using the formula and data referenced below .

Select the conducting material:

Resistivity (ρ): x 10-8 Ω/m
Enter the required frequency: MHz Relative Permeability (μr):
Skin Effect Depth: um

This calculator uses JavaScript and will function in most modern browsers. For more information see About our calculators

From Transmission Lines and Networks by Walter C. Johnson, McGraw-Hill 1963 p58.

Nominal depth of penetration for a conductor

[formula for skin depth]

Where ρ = Is the resisitivity of the conductor in Ω/m

f= frequency in Hertz

μ = Is the absolute magnetic permeability of the conductor

The absolute magnetic permeability (μ) = μo x μr

μo = 4π x 10-7 H/m

The values for μr are from Transmission Line Design Handbook by Brian C Wadell, Artech House 1991 Table 9.3.2 page 446.

The values for ρ are from CRC Handbook of Chemistry and Physics 1st Student Edition 1998 page F-88 and are for high purity elements at 20°C.

This calculator is provided free by Chemandy Electronics.

Return to Calculator Index


Calculator for the Inductance of a Flat Wire

Flat Wire Inductance Calculator

The inductance of a flat or ribbon wire (rectangular cross section), can be calculated using the following formula. The inductance of a track on a PCB can also be calculated with this.

[Formula for flat wire inductor]

Where l = Length in cm

w = Width in cm

t = thickness in cm (PCB copper @ 1 oz/ft2 = 0.035 mm)

The original for this formula is by F.E. Terman and can be found in the Radio Engineers Handbook, McGraw-Hill, New York, 1945. The units have been changed from µH to nH and the thickness from cm to mm for easier working on PCB's.

Enter the Length: | cm |
Enter the Width: | cm | Inductance: | nH
Enter the Thickness: | mm |

This calculator uses JavaScript and will function in most modern browsers. For more information see About our calculators

This calculator is provided free by Chemandy Electronics.

Return to Calculator Index


Calculator for Total Capacitance of a Circular Capacitor, including edge effect

The total capacitance of a circular parallel plate capacitor including edge effect, can be calculated using the following formula.

[Circular capacitor formula]

Where r = Radius in cm

εr = Relative Dielectric Constant

d = Dielectric thickness in cm

The calculator can be used to check results obtained with the Accurate Method for Measuring Relative Dielectric Constant of a PCB Using a Vector Network Analyser.

Enter the value of εr: |  |
Enter the radius of the circle: | cm | Total Capacitance: | pF
Enter the thickness of the dielectric: | mm |

This calculator uses JavaScript and will function in most modern browsers. For more information see About our calculators

The calculator uses the equation above, derived from Kirchhoff's formula for a circular capacitor

This calculator is provided free by Chemandy Electronics.

Return to Calculator Index


Characteristic Impedance Calculator

Characteristic Impedance Calculator for the Measurement of PCB Tracks and Coaxial Cables Using a Vector Network Analyser

Calculates Delay, Velocity Factor, Effective Dielectric Constant and Characteristic Impedance of a PCB track. This calculator can also be used for measuring coaxial cable and will then give Relative Dielectric Constant rather than Effective Dielectric Constant. The operation of this calculator can be better understood by first reading Measuring Characteristic Impedance and Effective Dielectric Constant of PCB tracks using a Vector Network Analyser

 | INPUT DATA |  | RESULTS
Frequency at + 900 (fa) : | MHz | Delay( tav) : | nS
SHORT R : | Ohms | Velocity Factor : |
SHORT J : | Ohms | Effective Dielectric Constant (εeff) : |
OPEN R : | Ohms | Characteristic Impedance Real (R) : | Ohms
OPEN J : | Ohms | Imaginary (j) : | Ohms
 |  | Characteristic Impedance (Zo) : | Ohms
Frequency at - 900 (fb) : | MHz | Averaged Measurement Frequency : | MHz
SHORT R : | Ohms |
SHORT J : | Ohms |
OPEN R : | Ohms |
OPEN J : | Ohms |
Completed Phase Revolutions: |  |
Mechanical Length: | cm |  |

This calculator uses JavaScript and will function in most modern browsers. For more information see About our calculators

The time delay (ta) at + 900 is found by dividing the total phase shift at the measured + 900 by the phase shift per second due to frequency

[Delay at plus ninety degrees formula] Formula 1.

Where f is the frequency in Hz at + 900

rev is the number of completed revolutions of phase before the + 900 is reached

Similarly the time delay (tb) at - 900 is found by dividing the total phase shift at the measured - 900 by the phase shift per second due to frequency

[Delay at minus ninety degrees formula] Formula 2.

The average time delay (tav) for + 900 and - 900 is then

[Average delay formula] Formula 3.

Finding the Velocity Factor

Equivalent delay in free space for a similar distance

[Delay in free space formula] Formula 4.

Where l is the length of the track

c is the speed of light in free space

[Velocity Factor Formula] Formula 5.

The Effective Dielectric Constant calculation is based on an article by Dr Eric Bogatin, but he uses imperial units and velocity. His article and incredible smile can be found at: http://www.bethesignal.net/bogatin/feature-articles-c-23.html

[Effective Dielectric Constant formula] Formula 6.

An average of the measurement frequencies is found

[Average Frequency formula] Formula 7.

The principal of deriving the Characteristic Impedance from an OPEN and SHORT measurement is based on Transmission Lines and Networks by Walter C. Johnson, McGraw-Hill 1963 p155 Para 4.7 Measurement of the Characteristics of lines.

[Short and Open formula] Formula 8

This calculation is combined for two adjacent measurements and so ripple (measurement error) caused by the mismatch of the VNA to the transmission line is also removed.

[Formula for Short and Open removing ripple] Formula 9.

W J Highton Updated 4/4/2008

This calculator is provided free by Chemandy Electronics.

Return to Calculator Index


Coplanar Waveguide With Ground Calculator

Coplanar Waveguide With Ground Characteristic Impedance Calculator

The characteristic impedance (Zo) of coplanar waveguide with ground or microstrip lines with signal side ground plane can be calculated using the active calculator or the formulas at the bottom of the page.

[diagram of PCB layers]

Where εr = Relative Dielectric Constant

W = Width of gap

S = Width of track

h = Thickness of dielectric

Enter the εr of the PCB: |  |  |
Enter the width of the track: | mm |  |
Enter the width of the gap: | mm | Effective Dielectric Constant (εeff): |
Enter the thickness of the dielectric: | mm | Characteristic Impedance (Zo): | Ohms

This calculator uses JavaScript and will function in most modern browsers. For more information see About our calculators

The original formulas are in Transmission Line Design Handbook by Brian C Wadell, Artech House 1991 page 79. The formulas use "a" for the track width and "b" for the sum of the track width plus the gaps either side.

[All formulas for Eeff and Zo calculation]

To avoid microstrip line modes, it is recommended that h >> b and that the component side ground extend away from the track on each side more than "b".

Note: For those who wish to understand how K(k) is found, there is a calculator and equations for Elliptical Integrals of the First Kind.

This calculator is provided free by Chemandy Electronics.

Return to Calculator Index


Elliptical Integrals of the First Kind Calculator

This calculator finds the elliptical integral K(k) and shows each successive step until the final result is obtained. This method of calculation is used in our Coplanar Waveguide With Ground Calculator and the equations used are shown below.

 |  | Enter value k: |  |
Iteration (n) | an | bn | cn | K(k) at iteration N = n
0 |  |  |  |
1 |  |  |  |
2 |  |  |  |
3 |  |  |  |
4 |  |  |  |
5 |  |  |  |
6 |  |  |  |
7 |  |  |  | K(k) = Solution

This calculator uses JavaScript and will function in most modern browsers. For more information see About our calculators

These recursive equations were originally give for use in calculating the inductance of helical coils and are taken from Miller, H Craig, "Inductance Formula for a Single-Layer Circular Coil" Proceedings of the IEEE, Vol. 75, No 2, February 1987, pp. 256-257.

The first iteration (n0) is calculated with the following formulas.

[Formula for the first iteration of a, b, c and K(k)]

Each successive iteration is then calculated with the following formulas until cN = 0 is within the required accuracy.

[Formula for the successive iterations of a, b, c and K(k)]

When cN = 0value the value for K(k) is the required answer.

This calculator is provided free by Chemandy Electronics.

Return to Calculator Index


Linest Function

Using the LINEST function in Microsoft Excel

The Microsoft Excel LINEST function is very useful when finding the Polynomial formula y = b + m1x + m2x^2 + m3x^3 + m4x^4 for a curve but the help information in Excel is a little difficult to understand. This description should make it a bit easier.

This function will only work if the appropriate Add-in has been installed. This can be verified by checking in the Excel toolbar:- Tools, Add-Ins, Analysis ToolPak.

Two columns of data are made containing the known X and Y coordinates of the curve. An example of this can be found at linearity-spreadsheet-01.xls where the X and Y columns represent the Signal Generator Output ( Volts) and the DVM Reading ( Volts) respectively.

To understand the use of the LINEST function copy the whole table(A4:A16,E4:E16) into a new spreadsheet.

Highlight the five cells (A22:E22) that are to contain the results and press F2 to select all five cells.

Enter the formula "=LINEST(B5:B16,C5:C16^{1,2,3,4})"

Press the CTRL + SHIFT + ENTER keys all together and the final calculation will be made.

An alternative method is given for the LOGEST function at Logest Function

Return to Understanding Coaxial RF Transmission Lines by Measurement and Calculation part2

Return to Technical Articles

This information is provided by Chemandy Electronics.


Logest Function

Using the LOGEST function in Microsoft Excel

The Microsoft Excel LOGEST function is very useful when finding the formula y = b*m^x for a curve but the help information in Excel is a little difficult to understand. This description should make it a bit easier.

This function will only work if the appropriate Add-in has been installed. This can be verified by checking in the Excel toolbar:- Tools, Add-Ins, Analysis ToolPak.

Two columns of data are made containing the known X and Y coordinates of the curve. An example of this can be found at log-spreadsheet-01.xls.

To understand the use of the LOGEST function either copy the whole table(A1:A12,B1:B12) into a new spreadsheet or delete the results (C18:D18 in the results box) in the existing spreadsheet and re-calculate.

Highlight the two cells that are to contain the results and select the LOGEST function from the toolbar at Insert/Function/Statistical/LOGEST and hit OK. The LOGEST box will appear and the cursor will be in the Known_y's box. Select the Y column (B2:B12) with the mouse and the cell references will appear in the Known_y's box.

Left click the mouse in the Known_x's box and select the X column (A2:A12) DVM Reading ( Volts) column with the mouse and the cell references will appear in the Known_x's box.

Left click the mouse in the Const box and enter a 1 for the constant which will ensure that b in the formula y = b*m^x is used.

Left click the mouse in the Stats box and enter a 0 for the stats which will ensure that the regression statistics are not returned.

Hit OK and then the keyboard function key F2 to enable both selected cells.

Press the CTRL + SHIFT + ENTER keys all together and the final calculation will be made.

Note: If the regression statistics are required, then a block of cells two wide and five deep needs to be selected before the function is inserted and 1 entered into the Stats box of the function.

Return to Technical Articles

This information is provided by Chemandy Electronics.


Matching Pi Attenuator Calculator

Calculates the resistor values, attenuation, minimum attenuation, impedance, reflection coefficient, VSWR and return loss of a matching Pi attenuator.

[pi attenuator circuit]

1) Enter the required input and output impedance and the required attenuation then press "Calculate" below to obtain the ideal resistor values.

Input Impedance: | Ohms | Ideal Shunt In resistor: | Ohms
Output Impedance: | Ohms | Ideal Shunt Out resistor: | Ohms
Required Attenuation: | dB | Ideal Series resistor: | Ohms
 |  | Minimum possible attenuation to achieve impedance match: | dB

2) Change the Preferred Resistor Values to those available then press "Calculate" below to obtain the resulting attenuator parameters.

Shunt In resistor: | Ohms | Forward Attenuation: | dB | Reverse Attenuation: | dB
Shunt Out resistor: | Ohms | Input Impedance: | Ohms | Output Impedance: | Ohms
Series resistor: | Ohms | Input VSWR: |  | Output VSWR: |
 |  | Input Reflection Coefficient: |  | Output Reflection Coefficient: |
 |  | Input Return Loss: | dB | Output Return Loss: | dB

This calculator uses JavaScript and will function in most modern browsers. For more information see About our calculators

The required input and output impedance are used to calculate the minimum attenuation possible for correct impedance matching with a formula from RF Design Guide, Systems, Circuits and Equations by Peter Vizmuller Published by Artech House ISBN 0-89006-754-6

[Minimum loss possible to achieve matching formula]

Where Zin is the characteristic input system impedance

and Zout is the characteristic output system impedance

Peter Vizmuller also gives formulas for calculating the resistor values directly. This calculator uses formulas that I have derived and first finds the output voltage with a source EMF of 2 Volts and therefore an input PD of 1 Volt.

[Voltage out formula]

The individual ideal resistor values can now be found.

[Ideal shunt in resistor formula]

[Ideal shunt out resistor formula]

[Ideal series resistor formula]

After selecting preferred values, simple series and parallel resistor calculations are used to find the attenuator input impedance, input voltage and output voltage. The source EMF is again assumed to be 2 Volts.

[Input impedance formula]

[Input Voltage formula]

[Output voltage formula]

The remaining formulas for Attenuation, Voltage Reflection Coefficient and VSWR are available at:-

EngRef.pdf

This calculator is provided free by Chemandy Electronics.

Return to Calculator Index


Matching T Attenuator Calculator

Calculates the resistor values, attenuation, minimum attenuation, impedance, reflection coefficient, VSWR and return loss of an impedance matching T attenuator.

1) Enter the required input and output impedance and the required attenuation then press "Calculate" below to obtain the ideal resistor values.

Input Impedance: | Ohms | Ideal Series In resistor: | Ohms
Output Impedance: | Ohms | Ideal Series Out resistor: | Ohms
Required Attenuation: | dB | Ideal Shunt resistor: | Ohms
 |  | Minimum possible attenuation to achieve impedance match: | dB

2) Change the Preferred Resistor Values to those available then press "Calculate" below to obtain the resulting attenuator parameters.

Series In resistor: | Ohms | Forward Attenuation: | dB | Reverse Attenuation: | dB
Series Out resistor: | Ohms | Input Impedance: | Ohms | Output Impedance: | Ohms
Shunt resistor: | Ohms | Input VSWR: |  | Output VSWR: |
 |  | Input Reflection Coefficient: |  | Output Reflection Coefficient: |
 |  | Input Return Loss: | dB | Output Return Loss: | dB

This calculator uses JavaScript and will function in most modern browsers. For more information see About our calculators

The required input and output impedance are used to calculate the minimum attenuation possible for correct impedance matching with a formula from RF Design Guide, Systems, Circuits and Equations by Peter Vizmuller Published by Artech House ISBN 0-89006-754-6

[Minimum loss possible to achieve matching formula]

Where Zin is the characteristic input system impedance

and Zout is the characteristic output system impedance

Peter Vizmuller also gives formulas for calculating the resistor values directly. This calculator uses formulas that I have derived and first finds the output voltage with a source EMF of 2 Volts and therefore an input PD of 1 Volt.

[Voltage out formula]

The individual ideal resistor values can now be found.

[Ideal series in resistor formula]

[Ideal shunt resistor formula]

[Ideal series out resistor formula]

After selecting preferred values, simple series and parallel resistor calculations are used to find the attenuator input impedance, input voltage and output voltage. The source EMF is again assumed to be 2 Volts.

[Input impedance formula]

[Input Voltage formula]

[output voltage formula]

The remaining formulas for Attenuation, Voltage Reflection Coefficient and VSWR are available at:-

EngRef.pdf

This calculator is provided free by Chemandy Electronics.

Return to Calculator Index


Measuring Characteristic Impedance of PCB tracks using a Vector Network Analyser Part 1

Measuring Characteristic Impedance and Effective Dielectric Constant of PCB tracks using a Vector Network Analyser

Introduction

After a PCB track width is calculated, it is a wise idea to check its Characteristic Impedance (Zo) before it is adopted for use in a project. It is also very useful to have some accurate data as benchmarks for checking the suitability of the many calculators that are available and a selection of sample tracks could be measured for this purpose. There is much information for using a Time Domain Reflectometer (TDR) in this measurement, but very little for using a Vector Network Analyser (VNA). One of the probable reasons for this is because it is not an easy measurement with a VNA. We have developed a VNA method which can show Zo over a wide bandwidth. This is of course difficult with a TDR, which has better resolution with a fast rise time (i.e. high frequencies, typically just greater than 1 GHz). Our method also shows the Effective Dielectric Constant (εeff), Electrical Delay, Velocity Factor and an approximation of the spot measurement frequencies.

Aim

i) To measure the Characteristic Impedance (Zo), Effective Dielectric Constant (εeff), Electrical Delay, Velocity Factor (Vf) over a wide frequency sweep for Microstrip tracks on FR4 PCB using a Vector Network Analyser (VNA) HP8753.

ii) To generate a graph of these results over a frequency bandwidth.

iii) To confirm the accuracy of these measurements using known information.

Samples

A sample PCB was manufactured, with three similar width tracks :-

i) SHORTED track 2 cm long.

ii) SHORTED track 22 cm long.

iii) OPEN track 22 cm long.

The tracks were separated by at least 0.5 cm of upper ground plane or 1.0 cm of blank PCB. Shorted ends were thoroughly grounded with multiple links through the double sided PCB. All ground planes were grounded with links at approximately every 5 mm.

All measurements were made via SMA connectors which were soldered directly onto the track and the ground plane. The board was tested on a wooden bench and the room was unscreened.

Method

The test method used was based on information gleaned from Transmission Lines and Networks by Walter C. Johnson, McGraw-Hill 1963 p155 Para 4.7 Measurement of the Characteristics of lines.

Mr. Johnson states "A common problem is the determination of of the characteristic impedance and propagation constant of a given transmission line which is physically available for measurement and test. These quantities can be found by the measurement of the input impedance of the line under two conditions: with the far end short-circuited, and with the far end open-circuited". He then arrives at the following formula.

W. C. Johnson Formula (4.49) [Formula for impedance] Formula 1

He then discusses the measurement points.

"If the line is almost an odd number of quarter wavelengths long, the angle βl will be nearly an odd integer times π/2 radians; then Zs(s) will approach an open circuit and Zs(o) will approach a short circuit. This makes accurate measurements difficult. On the other hand, if the line is almost an even number of quarter wavelengths long, then Zs(o) will be very large and Zs(s) will be small. It is convenient to have both impedances of the same order of magnitude, and when the length of line can be selected at will, we can arrange to have tan βl approximately equal to 1/ tan βl. This occurs when the line is an odd number of eighth wavelengths long. If the over-all attenuation is high, the variation of impedance with length is not so violent, and so it is not necessary to select the length with care".

As we are measuring a very short length of track and the attenuation is low, it is important to select the measurement point with great care. After a few tests it became apparent that the best measurement point is indeed at the odd number of eighth wavelengths long. This corresponds to + 900 indication on the HP8753 VNA. It was also found that phase of the OPEN track was not accurate enough for calculating ε eff, Electrical Delay and Velocity Factor. This is probably due to fringing or edge effect at the end of the open circuit track increasing the phase length as frequency increases. Therefore all phase references are made to the 22 cm SHORTED track.

Technical Article Index <1 2 3> Page Number


Measuring Characteristic Impedance of PCB tracks using a Vector Network Analyser Part 2

The method of extracting Eeff is similar to that used by Dr Eric Bogatin, but uses metric units and velocity factor. His article and incredible smile can be found at: http://www.bethesignal.net/bogatin/feature-articles-c-23.html

First the delay is calculated using the total phase shift of the measured 20 cm of the SHORT track at the test frequency.

[Formula for electrical delay] Formula 2

Where Ø = Total Phase Shift of track (degrees)

f = Frequency ( MHz)

Dr Eric Bogatin first calculates velocity, but velocity factor is a more useful parameter in the laboratory. Equivalent

[Formula for delay in free space] Formula 3

Where c = Speed of light = 30 (cm/nS)

l = mechanical length (cm)

[Formula for velocity factor] Formula 4

Where Vf = Velocity Factor

[Formula for effective dielectric constant] Formula 5

Where εeff = Effective Dielectric Constant

Removing Connectors From Results

One of the major problems with measuring a short electrical length is that the impedance of the connectors and terminations cause a large error because they are a large proportion of the measured circuit. This problem is avoided in this method in two ways.

i) The input connectors are three identical SMA connectors mounted tight against the PCB. This means that any variations in length for this part of the circuit is very small in relation to the overall measurement track length which is 22 cm long. The VNA is calibrated with RBW 300 Hz and Average = 16 in order to improve accuracy and then connected to the SHORT 2 cm PCB track. The phase length of the 2 cm track is removed from the test by performing a port extension with the VNA. This means that the measurement plane is 2 cm along the track. When the VNA is now connected to a measurement track, it measures the last 20 cm of the 22 cm track and ignores the first 2 cm and the connector.

ii) Two separate tracks are used for the OPEN and SHORT measurements. This removes the problem of using a SHORT or OPEN termination which have a short length with an impedance (probably 50Ω). The method also avoids the difficulty of physically shorting an open track without changing it's physical length.

Procedure

The VNA was calibrated and a port extension performed as per Method on page one. The OPEN track was connected first and the S11 trace stored in DISPLAY. The VNA was then transferred to the SHORT track and measurements were made at + 900 with each complete revolution of phase recorded. The data for each point was calculated and a graph constructed which is shown in Figure 1 below.

[Graph of Eeff, L, C and Zo v Frequency]

It can be seen the there is a ripple in Zo that is not present in the other three characteristics. This suggests that the measured amplitude has a ripple, but the measured phase does not. It can also be seen that the first measurement varies considerably from the others.

Technical Article Index < 1 2 3 > Page Number


Measuring Characteristic Impedance of PCB tracks using a Vector Network Analyser Part 3

Removing the Ripples

The results at +900 and -900are averaged by using Formula 1 for complex numbers, and simply adding together and dividing the sum by two for the others . This removes the ripples and the result is more representative of the measurement at 00. The effect of this is shown in Figure 2. Note that not only have the ripples been removed, but the first inductive measurement has dropped considerably also.

[Graph showing Eeff, L, C and Zo v Frequency]

Proof

There is a rise in impedance with frequency that could be a measurement error. In order to first eliminate this, a short piece (14 cm) of semi-rigid cable was measured by the same method and the result is compared with the microstrip in Figure 3.

[Graph showing Zo v Freqency]

It can be seen that the Semi-Rigid gives virtually a straight line at 50 Ohms, as would be expected of a cable of this quality. This proves that the measurement method does not introduce a slope and the rise in characteristic impedance with frequency for the measured microstrip is real. It is interesting to note that the microstrip is 50 Ohm at about 1400 MHz, and this is the sort of frequency that would correspond to the typical measurement rise time of a TDR. It would appear therefore, that the formula by Brian C Wadell which was used to calculate the Zo, is accurate only at the frequency typically measured by a TDR. This would also be true for the other two formulas used for our microstrip calculators.

Comparison of Results With Return Loss Measurements

Many return loss measurements of microstrip transmission line have been made in a FLEXI-BOX, which has a track length of 5.5 cm. This is not long enough to make characteristic impedance measurements, but is suitable data for comparison. The characteristic impedance of the 3.1 mm sample displayed in Figure 2 was used to approximate the expected return loss of the microstrip with the two mismatches that would be present with two connectors as used in the return loss measurement. This is compared with a typical return loss measurement made with a 3.0 mm microstrip fitted in a FLEXI-BOX in Figure 4.

[Return Loss Graph - S11 v Frequency]

There is good correlation between these curves which can be understood with the aid of the following analyses.

Firstly, consider the portion of curve below 600 MHz. The measurement in the FLEXI-BOX has a much better return loss than the calculated values. This is because the track has not yet started acting as a transmission line. The 3.0 mm wide track in the box is basically just a very small inductor between the input and output measurement ports at 0.3 MHz. At this frequency, a two inch nail would give similar results! As the frequency is increased, the impedance of the track increases until it behaves like a transmission line at 600 MHz.

The curve down from 600 MHz to 1400 MHz is indicative of the Zo rising from a calculated 47.4 Ohms at 600 MHz to the measurement system impedance of 50 Ohms. The return loss levels do not match exactly, but the minimum occurs at the same frequency which indicates both tracks are 50 Ohms at the same frequency.

From 1400 MHz upwards, the Zo increases from 50 Ohms until it reaches a calculated value of 54.19 Ohms at 2600 MHz. The shape of the curves matching quite well.

It is reasonable to assume from these observations that the rise of impedance over frequency and it's passing through the system impedance of 50 Ohms at approximately 1400 MHz are all real. It is a simple comparison using basic principles and needs no complicated calculations or advanced simulations.

Conclusions

1) The method is valid and gives results that compare favorably with previous return loss measurements.

2) The data obtained over a frequency sweep with a VNA is more useful than that which can be obtained with a TDR measurement, because it is possible to select a more accurate impedance at the required working frequency.

3) The method is suitable for coaxial cables.

The Characteristic Impedance Calculator for the Measurement of PCB Tracks and Coaxial Cables Using a Vector Network Analyser is accurate, but it is a little tedious to enter the large amount of data required for a full frequency sweep and it is necessary to check data entry carefully before calculation. If a large number of measurements are made and the results are required in a chart, it is preferable to use a spreadsheet.

16/1/2005 William Jeffrey Highton

Technical Article Index <1 2 3> Page Number


Microstrip Transmission Line Characteristic Impedance Calculator Using a Formula by Brian C Wadell

The characteristic impedance (Zo) of a microstrip transmission line can be calculated using the active calculator or the formulas at the bottom of the page.

[diagram of PCB layers] Where εr= Relative Dielectric Constant

W = Width of track

t = Thickness of track (1 oz/ft2 = 0.035 mm)

h = Thickness of dielectric

Enter the εr of the PCB: |  |
Enter the width of the track: | mm |
Enter the thickness of the track: | mm | Effective Dielectric Constant (εeff): |
Enter the thickness of the dielectric: | mm | Characteristic Impedance (Zo): | Ohms

This calculator uses JavaScript and will function in most modern browsers. For more information see About our calculators

The following formulas were derived from formulas used in an article by Rick Hartley 050rfdesign.pdf. It is not too clear from the article by Rick Hartley where to use εr and where to use εeff (although there is a note to use eeff instead of er). The substitutions selected give results that are almost identical to the "benchmarks" in IPC1999.pdf, and these benchmarks were obtained by numerical methods. The accuracy of results obtained from this calculator can be checked by making a sample PCB and measuring the resulting impedance. Guidance for this can be found at Measuring Characteristic Impedance of PCB tracks using a Vector Network Analyser.

The above formulas are in Transmission Line Design Handbook by Brian C. Wadell, Artech House 1991. The main formula is attributable to Harold A. Wheeler and was published in, "Transmission-line properties of a strip on a dielectric sheet on a plane", IEEE Tran. Microwave Theory Tech., vol. MTT-25, pp. 631-647, Aug. 1977. The effective dielectric constant formula is from: M. V. Schneider, "Microstrip lines for microwave integrated circuits," Bell Syst Tech. J., vol. 48, pp. 1422-1444, 1969.

This calculator is provided free by Chemandy Electronics.

Return to Calculator Index


Microstrip Transmission Line Impedance Calculator for PCB's

Microstrip Transmission Line Characteristic Impedance Calculator

The characteristic impedance (Zo) of a microstrip transmission line can be calculated using the active calculator or the formulas at the bottom of the page.

[diagram of PCB layers]

Where εr = Relative Dielectric Constant

W = Width of track

t = Thickness of track (1 oz/ft2 = 0.035 mm)

h = Thickness of dielectric

Enter the εr of the PCB: |  |  |
Enter the width of the track: | mm |  |
Enter the thickness of the track: | mm | Effective Dielectric Constant (εeff): |
Enter the thickness of the dielectric: | mm | Characteristic Impedance (Zo): | Ohms

This calculator uses JavaScript and will function in most modern browsers. For more information see About our calculators

The following formulas are from an article by Rick Hartley page 27 050rfdesign.pdf.

The formulas give results within 3% of the results obtained in IPC1999.pdf.

More calculators for transmission line can be found at http://www.circuitsage.com/tline.html

This calculator is provided free by Chemandy Electronics.

Return to Calculator Index


Microstrip Transmission Line Impedance Calculator Using The IPC-2141 Formula

Microstrip Transmission Line Characteristic Impedance Calculator Using The IPC-2141 Formula

The characteristic impedance (Zo) of a microstrip transmission line can be calculated using the active calculator or the formula at the bottom of the page.

[diagram of PCB layers]

Where ε r = Relative Dielectric Constant

W = Width of track

t = Thickness of track (1 oz/ft2 = 0.035 mm)

h = Thickness of dielectric

Enter the ε r of the PCB: |  |  |
Enter the width of the track: | mm |  |
Enter the thickness of the track: | mm |  |
Enter the thickness of the dielectric: | mm | Characteristic Impedance (Zo): | Ohms

This calculator uses JavaScript and will function in most modern browsers. For more information see About our calculators

The calculator gives very similar results to those in Table 1 of an article at IPC1999.pdf

The following formula is given in the above article by Polar Instruments.

Note that the "h", for dielectric thickness in this formula is omitted in some other Polar publications.

The original source of formula is IPC-2141: Controlled Impedance Circuit Boards and High-Speed Logic Design, April 1996.

IPC have their website at: http://www.ipc.org/ContentPage.aspx?pageid=PCB-Tools-and-Calculators

This calculator is provided free by Chemandy Electronics.

Return to Calculator Index


PCB Sample Size Calculator for Relative Dielectric Constant Measurements

The optimum size of a circular PCB sample for the measurement of εr can be calculated by entering the known and predicted data into the text boxes. The predicted data could be from the manufacturers/suppliers specification or just left at the default of 4.2, but if it is too far out it may mean repeating the process and performing the measurement on a second sample once the approximate value is know.

This calculator is intended to be used with the Accurate Method for Measuring Relative Dielectric Constant of a PCB Using a Vector Network Analyser The default values in the text boxes relate to the samples used in the article Measuring Relative Dielectric Constant using parallel plate method and a Vector Network Analyser

Please give us feedback on your use of this calculator, good or bad. It works fine with FR4, but is not yet proven for all available materials.

Enter the predicted εr of the PCB: |  | Maximum sample radius: | cm
Enter the thickness of the copper: | mm | Optimum sample radius: | cm
Enter the thickness of the dielectric: | mm
Note: 1 oz/ft2 of copper = 0.035 mm |  |  |

This calculator uses JavaScript and will function in most modern browsers. For more information see About our calculators.

Once the relative dielectric is known the required track width can be found by reference to a handbook, or by using a calculator. There are three calculators for Microstrip including the Microstrip Transmission Line Characteristic Impedance Calculator Using a Formula by Brian C Wadell. and one Coplanar Waveguide With Ground Calculator

Many more calculators can be found on the excellent RF Cafe website

http://rfcafe.com/references/spreadsheets/calculator-list.htm

1) The minimum frequency for proximity effect to become established is found first.

From Transmission Lines and Networks by Walter C. Johnson, McGraw-Hill 1963 p58.

Nominal depth of penetration for a copper conductor (δ) = 6.64 / √f cm

Where f = frequency in Hertz

From this a formula is derived to find the frequency that has a depth of penetration of one half of the copper thickness i.e. the lowest frequency that allows the proximity effect to become well established.

[Minimum frequency for proximity effect formula] Formula 1.

2) The minimum frequency is used to calculate the maximum capacitance value at a phase shift of 70o (Xc = 71.4 Ω). Thus ensuring that the result achieved at 90o is measured well above the minimum frequency.

[Maximum capacitance formula] Formula 2.

3) The maximum capacitance is used to find the approximate maximum radius.

From Kirchhoff's formula for a circular capacitor

Landau, L.D. & Lifschitz, E.M., (1987). Electrodynamics of Continuous Media. Oxford, England: Permagon Press, p. 19.

[Circular capacitor formula]

Where εr is the Relative Dielectric Constant

r is the radius in cm

d is the thickness of the Dielectric in cm

[First part of circular caapacitor formula]

[Approximate radius formula] Formula 3.

4) Using the approximate radius, an approximation is then found for the Logarithmic part of Kirchhoff's formula

[Logarithmic part of circular capacitor formula] Formula 4

5) A quadratic equation for maximum radius is then derived and solved using

[Quadratic equation formula]

[r max formula] Formula 5.

The resulting radius is then entered again into Formula 4 and Formula 5 and this process is repeated five times in order to reduce the small error caused by the approximation to a negligible amount.

6) The maximum area is found and then halved to find the optimum area.

[Optimum area formula] Formula 6

7) The optimum radius becomes.

[Optimum radius formula] Formula 7

W J Highton Updated 3/4/2008

This calculator is provided free by Chemandy Electronics.

Return to Calculator Index


Pi Attenuator calculator with results for resistance, attenuation, return loss, VSWR and reflection coefficient

Pi Attenuator Calculator

Calculates the resistor values, attenuation, 'impedance', reflection coefficient, VSWR and return loss of a Pi attenuator.

[pi attenuator formula]

1) Enter the system impedance and required attenuation then then press "Calculate" below to obtain the ideal resistor values.

System impedance: | Ohms | Ideal series resistor: | Ohms
Required attenuation: | dB | Ideal shunt resistor: | Ohms
2) Change the Preferred Resistor Values to those available then press " Calculate" below to get the resulting attenuator parameters.
Preferred series resistor: | Ohms | Attenuation: | dB
Preferred shunt resistor: | Ohms | Input Impedance: | Ohms
 |  | Reflection Coefficient: |
 |  | VSWR: |
 |  | Return Loss: | dB

This calculator uses JavaScript and will function in most modern browsers. For more information see About our calculators

The calculator uses simple Ohms law calculations, and more comprehensive formulas for Voltage Reflection Coefficient and VSWR which are available at:-

EngRef.pdf

This calculator is provided free by Chemandy Electronics.

Return to Calculator Index


Preferred Resistor Values

The following table shows resistor values in the most commonly available E series. The whole range can be found by multiplying or dividing by tens.

E12 (10%) | E24 (5%) | E48 (2%) | E96 (1%) | E192 (0.5%)
100 | 100 | 100 | 100 | 100
 |  |  |  | 101
 |  |  | 102 | 102
 |  |  |  | 104
 |  | 105 | 105 | 105
 |  |  |  | 106
 |  |  | 107 | 107
 |  |  |  | 109
 | 110 | 110 | 110 | 110
 |  |  |  | 111
 |  |  | 113 | 113
 |  |  |  | 114
 |  | 115 | 115 | 115
 |  |  |  | 117
 |  |  | 118 | 118
 |  |  |  | 120
120 | 120 | 121 | 121 | 121
 |  |  |  | 123
 |  |  | 124 | 124
 |  |  |  | 126
 |  | 127 | 127 | 127
 |  |  |  | 129
 |  |  | 130 | 130
 |  |  |  | 132
 | 130 | 133 | 133 | 133
 |  |  |  | 135
 |  |  | 137 | 137
 |  |  |  | 138
 |  | 140 | 140 | 140
 |  |  |  | 142
 |  |  | 143 | 143
 |  |  |  | 145
150 | 150 | 147 | 147 | 147
 |  |  |  | 149
 |  |  | 150 | 150
 |  |  |  | 152
 |  | 154 | 154 | 154
 |  |  |  | 156
 |  |  | 158 | 158
 |  |  |  | 160
 | 160 | 162 | 162 | 162
 |  |  |  | 164
 |  |  | 165 | 165
 |  |  |  | 167
 |  | 169 | 169 | 169
 |  |  |  | 172
 |  |  | 174 | 174
 |  |  |  | 176
180 | 180 | 178 | 178 | 178
 |  |  |  | 180
 |  |  | 182 | 182
 |  |  |  | 184
 |  | 187 | 187 | 187
 |  |  |  | 189
 |  |  | 191 | 191
 |  |  |  | 193
 | 200 | 196 | 196 | 196
 |  |  |  | 198
 |  |  | 200 | 200
 |  |  |  | 203
 |  | 205 | 205 | 205
 |  |  |  | 208
 |  |  | 210 | 210
 |  |  |  | 213
220 | 220 | 215 | 215 | 215
 |  |  |  | 218
 |  |  | 221 | 221
 |  |  |  | 223
 |  | 226 | 226 | 226
 |  |  |  | 229
 |  |  | 232 | 232
 |  |  |  | 234
 | 240 | 237 | 237 | 237
 |  |  |  | 240
 |  |  | 243 | 243
 |  |  |  | 246
 |  | 249 | 249 | 249
 |  |  |  | 252
 |  |  | 255 | 255
 |  |  |  | 258
270 | 270 | 261 | 261 | 261
 |  |  |  | 264
 |  |  | 267 | 267
 |  |  |  | 271
 |  | 274 | 274 | 274
 |  |  |  | 277
 |  |  | 280 | 280
 |  |  |  | 284
 | 300 | 287 | 287 | 287
 |  |  |  | 291
 |  |  | 294 | 294
 |  |  |  | 298
 |  | 301 | 301 | 301
 |  |  |  | 305
 |  |  | 309 | 309
 |  |  |  | 312
330 | 330 | 316 | 316 | 316
 |  |  |  | 320
 |  |  | 324 | 324
 |  |  |  | 328
 |  | 332 | 332 | 332
 |  |  |  | 336
 |  |  | 340 | 340
 |  |  |  | 344
 | 360 | 348 | 348 | 348
 |  |  |  | 352
 |  |  | 357 | 357
 |  |  |  | 361
 |  | 365 | 365 | 365
 |  |  |  | 370
 |  |  | 374 | 374
 |  |  |  | 379
390 | 390 | 383 | 383 | 383
 |  |  |  | 388
 |  |  | 392 | 392
 |  |  |  | 397
 |  | 402 | 402 | 402
 |  |  |  | 407
 |  |  | 412 | 412
 |  |  |  | 417
 | 430 | 422 | 422 | 422
 |  |  |  | 427
 |  |  | 432 | 432
 |  |  |  | 437
 |  | 442 | 442 | 442
 |  |  |  | 448
 |  |  | 453 | 453
 |  |  |  | 459
470 | 470 | 464 | 464 | 464
 |  |  |  | 470
 |  |  | 475 | 475
 |  |  |  | 481
 |  | 487 | 487 | 487
 |  |  |  | 493
 |  |  | 499 | 499
 |  |  |  | 505
 | 510 | 511 | 511 | 511
 |  |  |  | 517
 |  |  | 523 | 523
 |  |  |  | 530
 |  | 536 | 536 | 536
 |  |  |  | 542
 |  |  | 549 | 549
 |  |  |  | 556
560 | 560 | 562 | 562 | 562
 |  |  |  | 569
 |  |  | 576 | 576
 |  |  |  | 583
 |  | 590 | 590 | 590
 |  |  |  | 597
 |  |  | 604 | 604
 |  |  |  | 612
 | 620 | 619 | 619 | 619
 |  |  |  | 626
 |  |  | 634 | 634
 |  |  |  | 642
 |  | 649 | 649 | 649
 |  |  |  | 657
 |  |  | 665 | 665
 |  |  |  | 673
680 | 680 | 681 | 681 | 681
 |  |  |  | 690
 |  |  | 698 | 698
 |  |  |  | 706
 |  | 715 | 715 | 715
 |  |  |  | 723
 |  |  | 732 | 732
 |  |  |  | 741
 | 750 | 750 | 750 | 750
 |  |  |  | 759
 |  |  | 768 | 768
 |  |  |  | 777
 |  | 787 | 787 | 787
 |  |  |  | 796
 |  |  | 806 | 806
 |  |  |  | 816
820 | 820 | 825 | 825 | 825
 |  |  |  | 835
 |  |  | 845 | 845
 |  |  |  | 856
 |  | 866 | 866 | 866
 |  |  |  | 876
 |  |  | 887 | 887
 |  |  |  | 898
 | 910 | 909 | 909 | 909
 |  |  |  | 920
 |  |  | 931 | 931
 |  |  |  | 942
 |  | 953 | 953 | 953
 |  |  |  | 965
 |  |  | 976 | 976
 |  |  |  | 988
1000 | 1000 | 1000 | 1000 | 1000
 |  |  |  | 1010
 |  |  | 1020 | 1020
 |  |  |  | 1040
 |  | 1050 | 1050 | 1050
 |  |  |  | 1060
 |  |  | 1070 | 1070
 |  |  |  | 1090
 | 1100 | 1100 | 1100 | 1100
 |  |  |  | 1110
 |  |  | 1130 | 1130
 |  |  |  | 1140
 |  | 1150 | 1150 | 1150
 |  |  |  | 1170
 |  |  | 1180 | 1180
 |  |  |  | 1200
1200 | 1200 | 1210 | 1210 | 1210
 |  |  |  | 1230
 |  |  | 1240 | 1240
 |  |  |  | 1260
 |  | 1270 | 1270 | 1270
 |  |  |  | 1290
 |  |  | 1300 | 1300
 |  |  |  | 1320
 | 1300 | 1330 | 1330 | 1330
 |  |  |  | 1350
 |  |  | 1370 | 1370
 |  |  |  | 1380
 |  | 1400 | 1400 | 1400
 |  |  |  | 1420
 |  |  | 1430 | 1430
 |  |  |  | 1450

Return to Technical Articles


Radio Frequency and Microwave JavaScript Calculator Index

Calculator Index

Radio Frequency and Microwave JavaScript Calculator

These calculators are written in JavaScript.Further information is available in About our calculators

Characteristic Impedance Calculator for the Measurement of PCB Tracks and Coaxial Cables Using a Vector Network Analyser
An active calculator which computes Delay, Velocity Factor, Effective Dielectric Constant and Characteristic Impedance of a PCB track.

Circular Capacitor Calculator
Active calculator for a parallel plate, circular capacitor, showing the formula by Kirchhoff.

Coplanar Waveguide With Ground Calculator
Active calculator for Coplanar Waveguide with ground or Microstrip lines with signal side ground plane, showing the formula by Brian C Wadell.

Elliptical Integrals of the First Kind Calculator
Active calculator with equations for solving Elliptic Integrals of the First Kind.

Flat Wire Inductor Calculator
Active calculator for a flat wire, ribbon or PCB track showing the formula used.

Matching Pi Attenuator Calculator
A two part calculator which gives ideal and preferred value resistors, showing most formulas used and a link to the others.

Matching T Attenuator Calculator
A two part calculator which gives ideal and preferred value resistors, showing most formulas used and a link to the others.

Microstrip Characteristic Impedance Calculator Using a Formula by Brian C Wadell
An active calculator based on a formula by Brian C. Wadell. Used for calculating the Zo of PCB transmission lines, showing the formula used.

Microstrip Characteristic Impedance Calculator
Active calculator using a formula from an article by Rick Hartley, showing the formula used.

Microstrip Characteristic Impedance Calculator Using The IPC-2141 Formula
Active calculator using a formula from an article by Polar instruments, showing the formula used.

PCB Sample Size Calculator for Relative Dielectric Constant Measurements
An active calculator which selects the optimum size for a circular plane on a PCB. This is used for making relative dielectric constant measurements using a Vector Network Analyser.

Pi Attenuator Calculator
Active calculator for resistor values, attenuation, 'impedance', reflection coefficient, VSWR and return loss of a Pi attenuator.

Rectangular Capacitor Calculator
Active calculator for a rectangular parallel plate capacitor with edge effect, showing the formula used.

Relative Dielectric Constant Calculator for a Circular Capacitor
Active calculator based on a formula by Kirchhoff for a circular capacitor, showing the equations used.

Resonance Calculator
Active calculator for a capacitor / inductor tank circuit, showing the formula used.

Return loss and mismatch loss Calculator
Active return loss and mismatch calculator with results for absolute impedance, return loss, VSWR, reflection coefficient and mismatch loss

RF Trap With Attenuators
Active calculator with attenuation, return loss, reflection coefficient and VSWR . This calculator is specific to the circuit used in the RF Trap With Attenuators FLEXI-BOX.

Skin Effect Depth
Active calculator which calculates the skin effect depth for copper at a particular frequency.

Spreadsheet
An Excel spreadsheet with many simple calculations in 'blocks' that can be built up into fairly complex calculations by simply making the input cell of any block equal to the result of any other block. There are no locks on any of the cells and this spreadsheet could make good raw material for building your own personal version.

T Attenuator Calculator
Active calculator for resistor values, attenuation, 'impedance', reflection coefficient, VSWR and return loss of a T attenuator.

These calculators are provided free by Chemandy Electronics. Collected and packaged by nethouyi.

Copyright © 2018 CHEMANDY ELECTRONICS.


Relative Dielectric Constant Calculator

Relative Dielectric Constant Calculator for a Circular Capacitor

The relative dielectric constant (εr) of the dielectric in a parallel plate, circular capacitor can be calculated using the following formula.

Where r = Radius in cm

C = Capacitance in pico Farads

d = Dielectric thickness in cm

The calculator is intended for use with the Accurate Method for Measuring Relative Dielectric Constant of a PCB Using a Vector Network Analyser.

Enter the value of the capacitor: | pF |
Enter the radius of the circle : | cm |
Enter the thickness of the dielectric : | mm | Relative Dielectric Constant (εr)

This calculator uses JavaScript and will function in most modern browsers. For more information see About our calculators.

The calculator uses a derivation of Kirchhoff's formula for a circular capacitor

This calculator is provided free by Chemandy Electronics.

Return to Calculator Index


Measuring Relative Dielectric Constant using parallel plate method and a Vector Network Analyser

MEASURING RELATIVE DIELECTRIC CONSTANT OF PCB's USING PARALLEL PLATE METHOD AND A VECTOR NETWORK ANALYSER

Introduction

In order to produce PCB transmission lines with a good return loss, we needed a simple and accurate εr measurement method. As an example, to obtain 30 dB return loss requires a track with a characteristic impedance accuracy of better than 3%. This represents a variation of approximately -12.3 % to + 14.7 % in εr for 50 Ohm microstrip on 1.5875 mm thick FR4. When variables such as final exposed track size, etching, and variations in dielectric thickness are taken into account the εr measurement tolerance needs to be much less than this. With this in mind, the following investigation was made and a method evolved.

Aim

To measure the εr of FR4 PCB dielectric to within 1% tolerance using the parallel plate method and a Vector Network Analyser (VNA). To confirm the accuracy of this measurement using a known formula to calculate a 50Ω microstrip, manufacture a sample and measure the return loss.

Method

A series of tests was devised and sample PCB's were manufactured. Three PCB's were etched with four sample areas of 1, 4, 9 and 16 cm2. All sample areas were at least 1 cm from the next nearest sample and from the ground at edge of the board. All measurements were made at the centre of the sample using a semi-rigid cable with the centre conductor passing through the PCB. The phase length of this cable was removed from the test by performing a port extension with the VNA (HP 8753). The boards were tested on a wooden bench and the room was unscreened.

A further PCB with a microstrip was manufactured from the same sheet of material as used for PCB-A to PCB-C (in order to obtain a similar εr). This sample was used to confirm that the resulting return loss was satisfactory.

PCB-A

This has four square samples of 1, 4, 9 and 16 cm2 on the top, and a continuous ground plane on the bottom.

Measurements were made from 1 MHz to 1 GHz and the resultant εr (K) calculated with the following formula.

From Radio Society of Great Britain, Radio Reference Data Book, Sixth Edition p22.

C = 0.0885 KA / d Formula 1.

Where C = capacitance in pico Farads

K = dielectric constant

A = area of plate in square centimeters

d = thickness of dielectric in centimeters

From this, we can derive

d = 0.0885 KA / C

The thickness of the dielectric was carefully measured with a micrometer on PCB-B at a point where there was no copper. This measurement is critical and it was found that a vernier caliper does not have the required degree of precision. A number of measurements were made over the exposed dielectric area and a typical measured value was used.

After calculation of the dielectric constant, results of greater than 10 were discarded, because they were obviously wrong and cramped the scale of the valid results. The results of interest are shown below in Figure 1.

Figure 1

[Graph showing relative dielectric constant v Frequency]

It can be seen that the measured εr varies with both frequency and sample size. There is no single point where the curves all coincide. The minimum spread is 11.9% at 200 MHz. Clearly, the measurement accuracy is worse than 1%. It was decided that the measurement problem was related to the perimeter length to area ratio. i.e.

Sample 1 ) 1 square centimeter, perimeter length = 4 x 1 = 4 centimeter.

Ratio = 1 : 4

Sample 2 ) 4 square centimeter, perimeter length = 4 x 2 = 8 centimeter.

Ratio = 4 : 8

or Ratio = 1 : 2 etc

It was decided to change the bottom ground in order to reduce edge capacitance.

Technical Article Index <1 2 3> Page Number


Measuring Relative Dielectric Constant using parallel plate method and Vector Network Analyser Part 2

PCB-B

This has four square samples of 1, 4, 9 and 16 cm2 on the top, and a mirrored ground plane on the bottom. Measurements were made from 1 MHz to 1 GHz and the resultant εr (K) calculated the same as PCB-A. The results are shown below in Figure 2.

Figure 2

[Graph showing relative dielectric constant v Frequency]

Figure 2 shows that the measured εr still varies with both frequency and sample size, but the curves are a little closer together and have dropped slightly at the centre frequencies. There is still no single point where the curves all coincide. The minimum spread has now reduced to 6.9% at 200 MHz, but this is still too great.

Next, the samples were changed to circles because the circumference to area ratio of a circle is marginally lower than that of the perimeter to area ratio of a square of similar area.

PCB-C

This has four circular samples of 1, 4, 9 and 16 cm2 on the top, and a mirrored ground plane on the bottom. Measurements were made from 1 MHz to 1 GHz and the resultant εr (K) calculated the same as PCB-A. The results are shown below in Figure 3.

Figure 3

[Graph showing relative dielectric constant v Frequency]

Figure 3 shows that the measured εr still varies with both frequency and sample size, but the curves are again a little closer together and have dropped even more at the centre frequencies. There is still no single point where the curves all coincide. The minimum spread is now 4.6% at 200 MHz. Clearly, there is still a problem with the edge effect that the sample size and shape cannot overcome. It was decided to use a formula by Kirchhoff that takes into account the edge effect of a circular capacitor, which is what we now have!

From Landau, L.D. & Lifschitz, E.M., (1987). Electrodynamics of Continuous Media. Oxford, England: Permagon Press, p. 19.

CMKS = 4πεo Ccgs Formula 2.

Ccgs = (r2/4d) + r/4π [ln(16πr/d)-1] Formula 3.

Where r = radius

d = thickness of dielectric

εo = dielectric constant

CMKS = capacitance in metre - kilogram - second units

Ccgs = capacitance in centimetre - gram - second units

From Formula 1, 2, & 3 the following formula was derived.

[Formula for relative dielectric constant] Formula 4.

This formula is used in the Relative Dielectric Constant Calculator.

Technical Article Index < 1 2 3 > Page Number


Measuring Relative Dielectric Constant using parallel plate method and Vector Network Analyser Part 3

The εr was recalculated and the results are shown below in Figure 4.

Figure 4

[Graph showing relative dielectric constant v Frequency]

Figure 4 shows that the measured εr still varies with both frequency and sample size, but the curves of the two larger samples now coincide at 10 to 100 MHz. The curve of the smallest (1 cm2 ) sample has moved considerably from the other three and it is obvious that this sample is too small for accurate results. A closer examination shows that the 4 cm2 sample is also inadequate and it is not until the sample size reaches 16 cm2 that a reasonably smooth curve is produced. If the smallest sample is ignored, the minimum spread is now 1.3% at 5 MHz.

The next problem was to find the actual εr from the recalculated data. The text books tell us that the phase shift across a capacitor is 900, so the measurements were repeated at ten degree phase intervals. The results were again calculated with Formula 4 and are shown below in Figure 5.

Figure 5.

[Graph showing relative dielectric constant v Phase]

If the smallest sample is again ignored, the minimum spread is now 0.85% at 900. We are now in the right ball park area for measurement accuracy and a check is warranted.

PCB-D

This has one circular sample 16 cm2 on the top, and a mirrored ground plane on the bottom. The VNA was calibrated and the phase length of the semi rigid cable was removed from the test by performing a port extension. The capacitance at 900 was measured at the capacitor centre and the εr calculated at 4.254 using the circular capacitor method.

PCB-E

This PCB was manufactured from the same sheet as PCB-D in order to obtain a similar εr. This has a calculated 50Ω microstrip transmission line and the PCB fits into a FLEXI-BOX for the measurement. The track width was calculated at 2.87 mm using the microstrip calculator. This calculator was later updated and now indicates 2.861 mm for a 50Ω microstrip. However, the results for the 2.87 mm track are excellent and are shown below in Figures 6&7.

Figure 6

[Graph showing return loss v Frequency]

Technical Article Index < 2 3 4 > Page Number


Measuring Relative Dielectric Constant using parallel plate method and Vector Network Analyser Part 4

Figure 7

[Graph showing insertion loss v Frequency]

Continuing the study with larger Sample Sizes

Larger boards were made with single circles from a single sheet of material in order to find the optimum size for a sample. The circular capacitor method was used to calculate the εr and the results are shown in Figure 8.

Figure 8.

[Graph showing relative dielectric constant v Phase]

The two larger circles (248.17 and 122.52 square cm) do not coincide with the other two samples at 900. They are clearly too large but they do give some useful clues as to the method of selecting the optimum size, which will be discussed later.

Confirmation of Measurement Point

It is possible to confirm that the 900 point is the best measurement point, as can be seen from Figure 9 which includes some of the earlier results with smaller circles.

Figure 9.

[Graph showing relative dielectric constant v Phase]

It can be seen in Figure 9 that the circles of 60.24 cm2 and 4.00 cm2, coincide at 900 only. They are the largest and smallest possible sample sizes for the PCB material and only the result at 900 can be relied upon.

Technical Article Index < 3 4 5 > Page Number


Measuring Relative Dielectric Constant using parallel plate method and Vector Network Analyser Part 5

Maximum Size

The maximum size of a sample can be derived from a study of the three largest circles as shown in Figure 10.

Figure 10.

[Graph showing relative dielectric constant v Phase]

There are three peaks that occur at 140, 110 and 70 degrees. If these are examined in relation to frequency, there is a common result. They all occur just below the frequency that the proximity effect starts. This frequency is calculated the same as skin effect.

From Transmission Lines and Networks by Walter C. Johnson, McGraw-Hill 1963 p58.

For a copper conductor

δ = 6.64 / √f cm Formula 5.

Where δ = nominal depth of penetration in cm

f = frequency in Hertz

The copper on the sample board is 1/2 oz per square foot or 0.00175 cm thick. The proximity effect can be calculated as follows.

f = (6.64 / 0.00175)2 = 14.4 MHz

Table 1.

Area (cm2) | Phase at Peak (degrees) | Next Highest Phase (degrees) | Frequency at Peak (MHz) | Next Highest Frequency (MHz)
248.17 | 140 | 150 | 13.63 | 19.35
122.52 | 110 | 120 | 13.915 | 17.536
60.24 | 70 | 80 | 13.489 | 16.361

It can be seen in Table1, that the peak is just below the point at which the proximity effect starts. It can be concluded from this that the maximum size of the sample is dependant on the thickness of the copper plane.

We have not been able to obtain samples locally with a different copper thickness to prove that the frequency changes with copper thickness.

Minimum Size

This is more difficult to assess and it is probable that the errors present with a small sample are due to such things as the ratio of the drilled hole and countersink in relation to the overall size. The amount of solder applied and the general difficulties of measuring at more than 1 GHz. It is most likely that any sample under 1 cm radius would be unsuitable regardless of the materials used.

Conclusion

It can be seen from this study that the sample size, shape and mirror ground are all important. As is the connection method, port extension and sample connection point (central). The inaccuracies that can occur are considerable and comparisons are made in Figure 11.

Figure 11.

[Graph showing relative dielectric constant v Frequency]

The minimum error for a 16cm2 square with full ground plane is 18.5% at 50MHz, and this is probably typical of actual samples used by the unaware. If a microstrip transmission line of a required 50Ω is calculated from the resultant εr an actual characteristic impedance of 46.32Ω will be achieved.

Another point to note is that the Relative Dielectric Constant is just as it name implies, it is a constant and does not change very much at all over frequency. The combination of various circle sizes measured at 900 in Figure 11 shows a straight line (within measurement accuracy limits). As we have now observed, a curve over a frequency band is indicative of measurement error not a change in εr. It is not important to measure at a set frequency, although ε r is typically quoted by PCB manufacturers at 1 MHz. The proximity effect has not been established properly at such a low frequency and the figure should be regarded as suspect. Most equations available to calculate track dimensions do not use frequency and the ε r is assumed to be constant over frequency. It is very important that the measurement is made at 90° (regardless of frequency).

It is also important to get the right sample size and to assist with this, we have produced a PCB Sample Size Calculator for relative dielectric constant measurements. If in doubt start with a circle of 2.5 cm radius, this should cover most materials available.

Technical Article Index <3 4 5> Page Number W J Highton 24/10/2004


Return Loss and Mismatch Loss Calculator

Calculates the absolute load impedance, reflection coefficient, VSWR, return loss and mismatch loss of a load.

Enter the source characteristic impedance and the load impedance then press "Calculate" below.

Source Impedance: | Ohms | Absolute Load Impedance: | Ohms
Load Impedance R: | Ohms | Load Reflection Coefficient: |
Load Impedance J: | Ohms | Load VSWR: |
 |  | Load Return Loss: | dB
 |  | Load Mismatch Attenuation: | dB

This calculator uses JavaScript and will function in most modern browsers. For more information see About our calculators.

The absolute value of the load impedance is calculated from the complex impedance (R + j).

[absolute impedance formula]

Where R is the Real part of the impedance

and j is the Imaginary part of the impedance

The Load Reflection Coefficient ( Γ ) is calculated using the complex impedance of the load and the characteristic impedance of the source.

[reflection coefficient formula]

Where Zo is the Source Impedance

The VSWR is then calculated using the Reflection Coefficient

The Reflection Coefficient is used again to calculate the Return Loss

[return loss formula]

The Reflection Coefficient is used yet again to calculate the Mismatch Loss

Various formulas for Voltage Reflection Coefficient and VSWR are also available at:-

EngRef.pdf

This calculator is provided free by Chemandy Electronics.

Return to Calculator Index


RF Trap With Attenuator calculator with results for attenuation, return loss, VSWR and reflection coefficient

RF Trap With Attenuator Calculator

Calculates the attenuation, 'impedance', reflection coefficient, VSWR and return loss of a circuit that incorporates a RF tank circuit into a Pi attenuator. Preferred resistor values are entered into the text boxes, similar to the way that values for a prototype may be selected. Values for the tank circuit may be selected with the Tank Circuit Resonant Frequency Calculator. A FLEXI-BOX is available with a dedicated PCB for this circuit and there is a selection of connectors. This is supplied as a kit, or as a ready built RF Trap With Attenuators.

Characteristic impedance of the system: | Ohms | Attenuation: | dB
Enter the value of R2/R3 resistor: | Ohms | Impedance: | Ohms
Enter the value of R1/R4: | Ohms | VSWR: |
 |  | Reflection Coefficient: |
 |  | Return Loss: | dB

This calculator uses JavaScript and will function in most modern browsers. For more information see About our calculators.

This calculator uses simple Ohms law calculations, and more comprehensive formulas for Voltage Reflection Coefficient and VSWR which are available at:-

EngRef.pdf

This calculator is provided free by Chemandy Electronics.

Return to Calculator Index


RF Trap With Attenuators circuit description

RF Trap With Attenuators

Description

The RF Trap With Attenuators is intended for use in harmonic measurement. It is particularly useful when the available spectrum analyser's dynamic range is inadequate to directly measure the very small harmonics required in modern 'digital' communication transmitters. The ready built circuit attenuates the fundamental of the transmit frequency by more than 50 dB and the harmonics from 16 dB to about 22 dB (depending on the capacitor selected), thus reducing the required dynamic range of the spectrum analyser by approximately 30 db. Input and output attenuators are included to prevent the RF Trap With Attenuators from causing a serious mismatch with either the circuit under test or the spectrum analyser.

Measurement Technique

The maximum input level to the ready built version RF Trap With Attenuators should not be greater than +22 dBm (your design may differ from this, and the following may have to be re-calculated). If the output of the circuit under test is greater than +22 dBm, a power attenuator should be connected to the input of the RF Trap With Attenuators that will ensure that the +22 dBm input level is not exceeded. The output level of the RF Trap With Attenuators should then be =< 6 dBm (16 dB to 22 dB insertion loss!). This will ensure that the spectrum analyser input is not overloaded. Attenuators should be selected within the spectrum analyser to give less than -10 dBm at the input to the spectrum analyser input mixer stage when making the measurement. The insertion loss off the combined attenuators is first measured at the required fundamental and harmonic frequencies using a known signal source. This is normally a signal generator that has been calibrated to a power meter. The circuit under test is now connected to the combined attenuators and the fundamental and harmonics measured. Either the combined attenuator insertion loss is used to calculate the actual level at the output of the circuit under test or the output is measured using the spectrum analyser offset facility.

Circuit and Simulation Components with typical values

[circuit with simulation components]

Circuit Description

The resistors R1, R2, R3 and R4 form a pi attenuator. The centre of this pi attenuator is grounded via an RF Trap, formed by the series l/c circuit (L1, C1). The l/c component values are selected for resonance at the fundamental frequency of the test signal.

In the circuit diagram, the simulated input to the RF Trap With Attenuators is provided by V2 and R6. This represents a voltage source with an impedance of 50 Ohms at the COAXIAL INPUT. The COAXIAL OUTPUT is terminated by the 50 Ohm resistor R5 and monitored by a voltage level probe. The frequency is swept using the above circuit simulation and gives a frequency response as seen below. This simulation is an over simplification and ignores the effects of the PCB and component strays.

[Frequency response graph]

Availability

The RF Trap With attenuators can be purchased from Chemandy Electronics ready built in a FLEXI-BOX with the required fundamental frequency up to 1.0 GHz. (Our network analysers are capable of measuring up to 3 GHz and the response beyond this frequency is an unknown)

The circuit can also be built by you in a FLEXI - BOX, using values selected with the Calculator For RF Trap With Attenuators.

Return to Technical Articles


Understanding Coaxial RF Transmission Lines by Measurement and Calculation

Understanding RF Transmission Lines by Measurement and Calculation

1.1) Introduction

When a sine wave is passed into a transmission line, it's behavior is dependent on the conditions that it meets. The results can be complex and difficult to understand. Classical transmission line theory uses advanced mathematics and explanations that are not always logical. Some tutors use analogies in order to explain the principles and these often make it even more confusing. This study uses measurements of the constant sine waves and the resultant complex waveforms in a coaxial cable. The results of these measurements are processed with simple formulas and then made into charts with the aid of a spreadsheet, so that this visual data can be related to the, more mathematical, classical transmission line theory. The aim of the study is to give the student an understanding of what is really happening to the original sine wave and at the same time develop their skills with the mathematics and measurement techniques that are used every day in radio frequency technology.

A signal generator and a DVM are required plus the following test aids that we have developed specifically for the measurements.

1) Voltage and Current detector.

2) RF Bridge

3) Broadband Amplifier

4) Termination Box

The first item that is used and probably the one that needs most explanation is the Voltage and Current detector.

1.2) Principle of Sine Wave Detection with a Diode

A sine wave can be detected by a diode pump circuit as in Figure 1.1. If there is a signal input to the anode of the diode of 1.4 Volts peak (1 Volt rms) and the diode is a Schottky with a forward voltage drop of 0.2 Volts, then the DC level on the diode cathode will be 1.2 Volts. If a digital voltmeter is now connected to the output of the circuit and the potentiometer is adjusted to give a meter reading of 1 Volt. The dc output of 1.0 Volts now indicated by the meter, represents the rms voltage present at the anode of the diode.

Figure 1.1

[diode pump circuit]

This circuit functions well, as long as there is an adequate input voltage to the diode. When the input voltage to the diode anode nears the voltage drop of the diode the output voltage drops disproportionately and the circuit becomes non-linear. There are methods of forward biasing the diode in order to reduce these errors but it was considered more suitable to reduce the errors mathematically.

1.3 Mathematically Linearising a Detection Diode

Measurements are made at known voltage levels and the results are used to plot a curve. A formula is then fitted to the curve in order to find the constants for the diode in use. During our measurements, we will use a signal generator as the RF source and a DVM to monitor dc voltages. Most modern RF signal generators are 50 Ohms and indicate their output level in dBm, although some can indicate in Volts. DVM's indicate in volts and diode data is normally presented in Volts. We will therefore, use Volts as the common units.

If it is necessary to convert the signal generator output from dBm to Volts, we start by finding the voltage at the reference level of 0 dBm:

0 dBm = 1 mW into 50 Ohms

From Ohms law W = V2 / R

Change to Impedance V2 = W x Z

Substitute reference level Vref = (Wref x Z)^0.5 Formula 1.1

To find the voltage at a particular output power level:

From db = 20 x Log (V1/V2)

V1 = Alog(dB/20) x V2

Substitute required voltages Vout = ALog(dB/20) x Vref

Substituting Formula 1.1 for Vref Vout = ALog(dB/20) x (Wref x Z)^0.5 Formula 1.2

As an example, calculate the output voltage at +13 dBm:

V = ALog(13/20) x (0.001 x 50)^0.5

V = 4.467 x 0.2236 = 0.9988 Volts rms

We can now use Formula 1.2 (or the indicated signal generator output voltage) in a spreadsheet to give a range of signal generator output voltages related to one dB steps from - 10 dBm to +13 dBm. The generator output level in dB is placed in ascending order in the first column (A). The voltage calculation and its result is placed in the second column (B). This has been done for you in linearity-spreadsheet-01.xls, but it is better experience if you generate your own spreadsheets.

1.4) Plotting the Diode Curve

The Voltage and Current Detector is connected directly to the output of the Signal Generator, or with an adaptor and is terminated with a 50 Ohm load as shown in Figure 1.2. The Signal Generator output is set to +13 dBm (or 1 Volt rms) at a frequency of 50 MHz. The DVM is connected to the Voltage and Current Detector, voltage output and should indicate approximately 1 Volt.

Figure 1.2

[test set up]

Technical Article Index < 1 2 3 > Page Number


Understanding Coaxial RF Transmission Lines by Measurement and Calculation Page 2

The voltage readings are taken at each power level in the spreadsheet and the voltage indicated by the DVM entered into the third column (C). From the second and third columns (B&C), a xy chart can be constructed that is similar to Figure 1.3.

Figure 1.3

[Graph of detected voltage vs input voltage]

1.5) Finding the Voltage Correction Constants

It can be seen in Figure 1.3 that the linearity of the diode pump circuit is poor below an input level of about 200 mV rms. The curve has now become a near square law and this can be used to advantage if a low power measurement is being made. However, we are measuring voltage and in order to make the voltage detection more linear using calculation, we first find the constants for the formula that fit the curve. This can be performed in Excel using the LINEST Function. Simply select the function and enter the DVM reading and the input voltage as the x and y data respectively. Excel will calculate results and these are required in the form y = b + m1x + m2x^2 + m3x^3 + m4x^4 which translates into Actual Voltage = b + m1*(DVM Reading)+ m2*(DVM Reading)^2 + m3*(DVM Reading)^3 + m4*(DVM Reading)^4. Whenever a reading is taken from the voltage detector output, just feed the DVM voltage reading into this formula with the appropriate constants and the correct signal voltage level will be calculated.

1.6) Principle of the Current Detection Circuit

The input signal to the circuit is passed through a current transformer as can be seen in Figure 1.4. The resultant current in the secondary of the transformer develops a voltage across a load resistor to ground. This resistor flattens the frequency response and matches the transformer output impedance to the amplifier input impedance. The amplifier produces an output voltage level similar to the voltage level present at the signal input to the current transformer. This ensures that the detection diode on the output of the amplifier has adequate voltage to perform mainly in the linear part of the response curve and works in a similar voltage region to the voltage detection circuit described previously.

Figure 1.4

[Circuit of current detector]

1.7) Plotting the Current Curve

The Voltage and Current Detector is connected directly to the output of the Signal Generator, or with an adaptor and is terminated with a 50 Ohm load as shown in Figure 1.2. The Signal Generator output is set to +13 dBm (or 1 Volt rms) at a frequency of 50 MHz. The DVM is connected to the Voltage and Current Detector, current output and should indicate approximately 200 mV. This represents ten times the rms current of 20 mA in the primary of the current transformer ( If the output potentiometer of the detector circuit is adjusted to give a 20 mV reading it will be difficult to get a good reading at low input power levels when the detected dc voltage approaches the noise level of the DVM test leads).

The input current is calculated from simple Ohms law using the input voltage calculated in the second column (B) of Spreadsheet_01.

I = V / R

Change into mA and impedance I = (V x 1000) / Z mA Formula 1.3

For an input of +13 dBm or 0.9988 Volts this is:-

I = (0.9988 x 1000) / 50 = 19.98 mA

We now use Formula 1.3 to calculate the input current for the range of signal generator output voltages in the second column (B) in the spreadsheet. The calculated input current is placed in the fourth column (D). Current readings are taken at each power level in the spreadsheet and entered into the fifth column (E). From the fourth and fifth columns (D&E), a xy chart is generated that should appear similar to Figure 1.5.

Figure 1.5

[Graph input current vs detected current]

1.8 Finding the Current Correction Constants

We now find the formula that fits the current curve. This can again be performed in Excel using the LINEST function. Simply select the function and enter the DVM reading divided by ten, and the input current as the x and y data respectively. Excel will calculate the constants for the formula in the form y = b + m1x + m2x^2 + m3x^3 + m4x^4, which now translates into actual current = b + m1x(DVM reading/10) + m2x(DVM reading/10)^2 + m3x(DVM reading/10)^3 + m4x(DVM reading/10)^4. Whenever a reading is taken from the current detector output, simply feed the result into this formula with the appropriate constants and the correct current is calculated.

Technical Article Index < 1 2 3 > Page Number


Understanding Coaxial RF Transmission Lines by Measurement and Calculation Page 3

2.1) Impedance of Terminations, Signal Generators and Coaxial Cables

In the application of a coaxial transmission line, it is normally necessary to match both the signal source impedance and the load impedance to that of the coaxial cable in order to ensure the maximum power transfer and minimum reflections. In the majority of RF and Microwave systems, there is a single characteristic impedance. The most common industry standard being 50 Ohms. The following measurements prove that the impedance of a termination, signal generator and load are all 50 Ohms.

2.2) Termination Impedance

In paragraph 1.4, the input voltage to the termination with +13 dBm at 50 MHz was measured as 1 Volt. In paragraph 1.7, the input current to the termination with +13 dBm at 50 MHz was measured as 20 mA. Using Ohms law, we can easily calculate the impedance of the termination.

R = V/I

Substituting Z for R Z = V/I Formula 2.1

Z = 1/.02 = 50 Ohms

This proves that the LOAD termination is 50 Ohms at 50 MHz.

2.2) Signal Generator Source Impedance

The theoretical output circuit of a signal generator with an output of 1 Volt rms, or approximately +13 dB, is shown in Figure 2.1. The generator has a source resistance (Rs) of 50 Ohms. This matches the signal generator source to any 50 Ohm cables or equipment at the output.

Figure 2.1

[Theoretical output circuit of signal generator]

We first measure the Signal Generator output voltage with the LOAD Termination and then again without the LOAD Termination, in order to demonstrate the source impedance of the Signal Generator. The Voltage and Current Detector is working in a linear part of its range, so there is no need to linearise the indicated readings for this measurement.

The Voltage and Current Detector is connected directly to the output of the Signal Generator and is terminated with a 50 Ohm load as shown in Figure 1.2. The Signal Generator output is set to +13 dBm at a frequency of 50 MHz. The DVM is connected to the Voltage and Current Detector, voltage output and should indicate approximately 1 Volt rms (20 mA into 50 Ohms). The measured voltage of 1 Volt rms, represents the Potential Difference (PD) at the output socket of the Signal Generator into the 50 Ohm LOAD Termination ( Rl).

The LOAD Termination is now removed and the indicated voltage is doubled to 2 Volt rms. There is now no current flowing in the source resistance (Rs) of the Signal Generator and therefore no voltage drop across it. The V/C Detector is now measuring the Electro Motive Force (EMF) of the voltage source in the Signal Generator.

With the 50 Ohm termination connected, the generator output (PD) was 1 Volt rms at 20 mA. The voltage across Rs (EMF - PD) was therefore also 1 Volt. So, Rs must be 1 Volt / 0.02 Amps = 50 Ohms.

We have now proven that the signal generator source resistance (Rs), or more correctly the signal generator impedance and the LOAD termination impedance are 50 Ohms at 50 MHz.

2.3) Coaxial Cable Characteristic Impedance

A coaxial cable has a characteristic impedance that is dependent on the materials used, the dimensions of the cable, and the frequency of the applied signal. This impedance can be calculated using Formula 2.1.

[Formula for Zo] Formula 2.2

Where:

Zo is the characteristic impedance.

R is the distributed resistance per unit length (Ohms/metre).

L is the distributed inductance per unit length (Henrys/metre).

G is the distributed conductance per unit length (Siemens/metre).

C is the distributed capacitance per unit length (Farads/metre).

The effect that the coaxial cable has in a circuit is related to the cable length, characteristic impedance and the operating frequency of the system. As the cable length increases, the input impedance approaches the characteristic impedance and the termination on the other end has less effect. With a theoretical infinite length cable the input impedance is equal to the characteristic impedance regardless of what terminates the other end. For this reason, when measuring the characteristic impedance of a cable it is advisable to use a reasonably long length and a two metre length is adequate for the frequencies used in the next measurement. The selected coaxial cable for the demonstration is RG223, which is a good quality cable and its characteristic impedance is close to the ideal of 50 Ohms.

The coaxial cable of length two metres is fitted between the Voltage and Current Detector and the LOAD Termination as per Figure 2.2. The Voltage and Current Detector is connected directly to the output of the Signal Generator or with an adaptor. The signal generator is set to give an output of +13 dBm ( or 1 Volt rms ) at a frequency of 50 MHz. The indicated voltage and current are recorded.

Figure 2.2

[Test set up for cable impedance measurement]

The Voltage and Current Detector is working at its calibration point, so there is no need to linearise the indicated readings.

The measurement results can now be used to calculate the impedance of the Coaxial Cable using:-

Z = V/I Formula 2.1

As can be seen from the calculation results, the impedance remains at 50 Ohms with the cable fitted.

We have now proven by measurement that the LOAD Termination, Signal Generator, and Coaxial Cable all have an impedance of 50 Ohms.

Technical Article Index < 2 3 4 > Page Number


Understanding Coaxial RF Transmission Lines by Measurement and Calculation Page 4

3.1) Coaxial Cable Attenuation

The attenuation of a cable is a function of the resistance of the conductors, the dielectric loss, the ratio between diameters of the inner and outer conductors, the length of the cable and the frequency of operation. It is possible to establish the attenuation at different frequencies and with different cable lengths using the Voltage and Current Detector.

3.2) Coaxial Cable Attenuation per Metre

The next measurement establishes the attenuation of two different length Coaxial Cables. These cable attenuation measurements are more easily performed on a higher loss coaxial cable e.g. RG58, but they can be performed on RG223 if care is taken. The measurement frequency is increased to 100 MHz in order to be able to able to be able to compare results obtained with manufacturers data.

INPUT POWER FOR 2 METRE CABLE

The test equipment is connected as per Figure 2.2. The Signal Generator is set to give an output of +13 dBm ( or 1 Volt rms ) at a frequency of 100 MHz. The input power to the 2 Metre Coaxial Cable is obtained by first recording the indicated input Voltage and Current . The voltage and current results are then entered into the correction formulas and the linearised result obtained. These results can now be used to calculate the input power to the Coaxial Cable using Formula 3.1 and this becomes (P1).

P = V x I Watts Formula 3.1

The input power should be approximately 20 mW at +13 db.

OUTPUT POWER FOR 2 METRE CABLE

The equipment is now reconfigured as per Figure3.1.

Figure 3.1

[Test set up to measure output power]

With the Signal Generator still set to give an output of +13 dBm at a frequency of 100 MHz. The output power from the Two Metre Cable is obtained by first recording the output Voltage and Current. This data is entered into the correction formulas and the linearised result obtained. These results can now be used to calculate the output power from the Coaxial Cable using Formula 3.1 and this becomes P2. We can now calculate the attenuation in dB.

Power Ratio dB = 10 Log P1/P2 Formula 3.2

This is the insertion loss at 100 MHz for 2 metres of cable.

ATTENUATION OF 1 METRE CABLE

The Two Metre Cable is now replaced with the One Metre Cable, the input power and output power measurements repeated for the 1 metre of cable and the insertion loss calculated.

As can be seen, the insertion loss of the Two Metre Cable is approximately twice that of the One Metre Cable, thus proving that attenuation is proportional to cable length. The attenuation of coaxial cable is normally quoted in dB/100ft or dB/10m. A comparison can be made between the result obtained and the cable manufacturers data.

Technical Article Index < 3 4 5 > Page Number


Understanding Coaxial RF Transmission Lines by Measurement and Calculation Page 5

3.3) Coaxial Cable Attenuation with Frequency

The attenuation of a cable is a function of the resistance of the conductors, the dielectric loss, the ratio between diameters of the inner and outer conductors, the length of the cable and the frequency of operation. The Two Metre Cable is now measured at a lower frequency and the result obtained compared with the earlier result in paragraph 3.2 to demonstrate the decrease in insertion loss. In this measurement, RG58 will again give easier results than RG223, but it requires the same cable as used previously in order to compare the results.

INPUT POWER

The test equipment is connected as per Figure 2.2. The Signal Generator is set to give an output of +13 dBm ( or 1 Volt rms ) at a frequency of 1 MHz.The input power to the Two Metre Cable is obtained by first recording the input Voltage and Current and then linearising the results. The power is then calculated with Formula 3.1.

Formula 3.1 P = V x I Watts

OUTPUT POWER

The equipment is now reconfigured as per Figure 3.1. With the Signal Generator still set to give an output of +13dBm at a frequency of 1 MHz. The output power from the Coaxial Cable is obtained by first recording the output Voltage and Current, and then linearising the results. These results are now be used to calculate the output power from the Coaxial Cable using Formula 3.1

ATTENUATION

The attenuation of the coaxial cable at 1 MHz is now calculated using Formula 3.2

Power Ratio dB = 10 Log P1/P2

This is the insertion loss at 1 MHz for 2 metres of cable. When this result is compared with the insertion loss at 100 MHz for the same 2 metre cable measured in 3.2, it can be clearly seen that there is a decrease in the attenuation of the Two Metre Cable with a decrease in frequency. Thus proving that the attenuation of a coaxial cable is dependent on frequency.

4.1) Reflection in a Coaxial Cable

It is normally necessary to match the load impedance of a cable in order to ensure the maximum power transfer and minimum reflection. When a signal in a coaxial cable is passed to an unmatched termination there is a reflected signal returned from the termination end of the cable towards the signal source. The power level of this signal can be measured with the aid of a directional device known as an RF bridge. The RF Bridge supplied by Chemandy Electronics has a working band well exceeding the frequencies used in the measurements, it has a frequency response from 0.3 MHz to 300 MHz and is a 50 Ohm instrument.

The measurements now become a little more difficult because of the high level of reflected signal. This reflected signal can cause leveling problems within the Signal Generator output circuit. In order to avoid these problems the Signal Generator is buffered with the Broadband Amplifier. This increases the signal level internally to approximately + 23 dBm. The signal then passes through an internal 6db attenuator to the output, resulting in greater than +15 dBm at the attenuator output. This slightly higher test level will also cause the detector circuits in the V/C Detector to work over a more linear range.

In order to be able to reflect the signal, we use the Termination Box. This has a 50 Ohm termination and also short and open circuits of approximately equal electrical length. These equal lengths will become important at a latter stage, when the comparative phases of forward and reflected signals are measured.

FORWARD POWER

The test equipment is connected as per Figure 4.1.

Figure 4.1

[Test set up for forward power]

Technical Article Index < 4 5 6 > Page Number


Understanding Coaxial RF Transmission Lines by Measurement and Calculation Page 6

With a 50 Ohm BNC Termination connected to the output of the Voltage and Current Detector and the Termination Box 50 Ohm LOAD connected to the free end of the 2 metre cable. The Signal Generator is set to 0 dBm at a frequency of 100 MHz. This gives a Broadband Amplifier output of approximately +15 dBm or approximately 1.26 Volt rms. at 0.025 Amps rms into 50 Ohms.

These results are recorded in Forward section of Table 1. The Signal Generator frequency being set to 1 MHz, 10 MHz and 100 MHz for the three columns. The results are recorded in the Forward section of table 4.1. The Termination Box is now selected for the OPEN and SHORT terminations in turn and the appropriate results entered into the forward section of Table 1. There is little point in linearising these results, because it is only the relative values that are of interest. Only the voltage is recorded because measurements are made into the same 50 Termination connected to the Voltage and Current detector and therefore indicate relative power without the need for measuring current. It can be seen from the results entered into Table 4.1, that the forward power/voltage drops slightly as the input frequency is increased (mainly due to losses in the input cable and the Voltage and Current Detector), but is virtually unaffected by the type of termination on the coaxial cable.

Table 4.1

Measurement | 1 MHz | 10MHz | 100MHz
FORWARD |  |  |
Forward Volts into 50 Ohms |  |  |
Forward Volts into S/C |  |  |
Forward Volts into O/C |  |  |
REVERSE |  |  |
Reverse Volts into 50 Ohms |  |  |
Reverse Volts into S/C Ohms |  |  |
Reverse Volts into O/C |  |  |

REVERSE POWER

The equipment is now reconfigured as per Figure 4.2.

Figure 4.2

[Test set up for reverse power]

With the RF Bridge now reversed, the reflected voltage is measured. The results are again taken and this time entered into the Reverse section of Table 1. It can be seen from these results in Table 1, that the reflected power is not only slightly reduced by a higher frequency as per the forward power measurements, but is also very dependent on the kind of termination in use. The OPEN and SHORT reflecting a fairly constant signal level and the LOAD termination reflecting none. The reverse power from the OPEN and SHORT are slightly lower than the forward power because the signal has to travel to the termination and return, thus incurring two times the cable attenuation.

This measurement demonstrates that the forward signal power level is unaffected by the termination on the end of the cable, and that an OPEN or SHORT termination give a total reflection of the signal.

5.1) Velocity of Propagation

The velocity of a signal in free space or an air line is approximately 3 x 108 m/s. The velocity of a signal in a coaxial cable is less than that in free space and is mainly dependent on the properties of the dielectric. A low loss coaxial cable working at high frequencies has a velocity of propagation that can be calculated from Formula 5.1.

[calculation formula] Formula 5.1

Where: v is the velocity of propagation in m/s

C is the distributed capacitance per unit length

L is the distributed inductance per unit length

Technical Article Index < 5 6 7 > Page Number


Understanding Coaxial RF Transmission Lines by Measurement and Calculation Page 7

5.2) Velocity Factor of a Coaxial Cable

It is possible to measure the velocity factor of a transmission line using the Voltage and Current Detector to detect phase cancellation. If a reflected signal in a coaxial cable is due to an OPEN termination, then at a point a quarter wave length from that OPEN termination the reflected sine wave will be 180 degrees out of phase with the forward sine wave and a voltage cancellation will result. The Two Metre Cable is used to determine the velocity factor using this cancellation effect.

For a 2 metre cable that is a quarter wavelength (λ/4)

A full wavelength (λ) is 2 x 4 = 8 m.

The frequency of a signal of wavelength λ can be calculated from:-

[Calculation formula] Formula 5.2

Where λ is the wavelength in metres

F is the frequency in MHz

In free space the frequency of a signal of wavelength 8 metres would be

The test equipment is connected as per Figure 5.1

Figure 5.1

[Test set up for velocity factor]

The Signal Generator is set to give an output of +0 dBm at a frequency of 37.5 MHz. This gives an amplifier output of approximately +15 dBm (1.26 Volt rms. at 0.025 Amps into 50 Ohms). The OPEN Termination is connected to the output of the Two Metre Cable.

While observing the DVM, the Signal Generator frequency is slowly reduced until a voltage null is reached. The frequency of the Signal Generator and the indicated voltage are recorded. The overall length of the coaxial cable is measured from the red line of the Voltage and Current Detector along the Two Metre Cable to the red line on the OPEN Termination, and the test assembly length is recorded. The Velocity Factor is calculated using Formula 5.3.

[Calculation formula] Formula 5.3

Where Vf is the velocity factor (there are no units)

Fg is the Signal Generator frequency for λ/4 in Hz

L is the length of the cable in metres

The result obtained can be compared with the manufacturers quoted velocity factor.

Note that the voltage null does not reach zero. This is because the reflected sine wave has a lower voltage than the forward sine wave due to the attenuation of the cable. The difference of these two values is therefore greater than zero. We record this voltage for use in the next measurement. This result also proves that the Voltage and Current Detector measures the SUM voltage of the forward and reflected sine waves.

Technical Article Index < 6 7 8 > Page Number


Understanding Coaxial RF Transmission Lines by Measurement and Calculation Page 8

5.3) Forward Voltage in a Coaxial Cable

We proved in 4.1 that the forward signal power level in a coaxial cable remains constant regardless of the impedance of the termination on the end of the cable. In this measurement it is demonstrated that the forward voltage remains constant regardless of the termination used. The forward input voltage into the cable is measured first, followed by a measurement of the output voltage. The results are used to calculate the sum input voltage which is then compared with the measured sum input voltage recorded in 5.2.

MEASURING FORWARD VOLTAGE

The equipment is still connected as per Figure 5.1 and the signal generator frequency Fg is left set for a voltage null at the Voltage and Current Detector. (Ensure that the null (sum) voltage into the OPEN Termination is recorded as per paragraph 5.2). The OPEN Termination is now replaced by the LOAD Termination and so there is no reflected signal. The measured sum input voltage is therefore actually the forward input voltage. This input voltage to the coaxial cable is recorded and the result linearised.

MEASURING OUTPUT VOLTAGE

The Voltage and Current Detector is now moved to the end of the Two Metre Cable and the LOAD Termination is fitted as in Figure 5.2

Figure 5.2

[Test set up for output voltage]

The forward output voltage of the coaxial cable is recorded and the result is linearised.

The voltage drop for the return trip can now be calculated using Formula 5.4 and the reflected voltage found.

Reflected Voltage (Vr ) = Vout2 / Vf Formula 5.4

The forward voltage and reverse voltage are 180° out of phase, therefore the sum voltage is a simple subtraction.

Calculated Sum Input Voltage = Vf - Vr

The Calculated Sum Input Voltage can now be compared to the measured result obtained in 5.2 and it can be clearly seen that they are virtually the same. Thus demonstrating that the forward voltage remained constant at the input to the cable, even though the termination on the output was changed from OPEN to LOAD. It follows that if both the power and the voltage have remained constant, then the current must also have remained constant, because P = V x I. This measurement can be repeated using current measurements if further proof is required. The termination is replaced by a SHORT for the sum input current measurement and the generator frequency remains unchanged. The results of the calculated sum current and the measured sum current are similar proof that the input conditions remain unchanged by the termination at the end of the cable.

Technical Article Index < 7 8 9 > Page Number


Understanding Coaxial RF Transmission Lines by Measurement and Calculation Page 9

6.1) Complex Impedance

In paragraph 4.1, it was shown that the termination had no effect on the forward power. In paragraph 5.3, it was shown that the termination has no effect on the forward voltage. If the forward power and voltage remain constant, then the forward current must also remain constant because P = V x I. The input (forward looking) impedance must also remain constant because Z = V / I and is therefore 50 Ohms regardless of the termination at the end of the two metre cable.

The results obtained for Vr and Ir in paragraph 5.3 can be used in Formula 2.1 to find the reverse looking impedance at the input of the cable using:-

Z = V/I Formula 2.1

The reverse looking impedance also calculates at 50 Ohms.

This approach does not agree with classical transmission line theory. The results of the measurements at the cable input into the OPEN or SHORT Terminations can be used to calculate the complex impedance at this point from a more traditional stand point using the following definition and formula taken from, TRANSMISSION LINES AND NETWORKS. INTERNATIONAL STUDENTS EDITION by Walter C. Johnson, 1963 by McGraw-Hill Book Co. Singapore ISBN 0-07-Y85348-7, Page 96.

The impedance of a transmission line at any point is defined as the complex ratio of E to I at that point.

Z = E / I

Where Z is the impedance.

E is the complex sum voltage.

I is the complex sum current.

Z = E / I

These calculations will give an impedance of nearly zero Ohms ( a short) for the OPEN Termination measurement and infinity ( an open) for the SHORT Termination. We have a conflict in approach here and both methods are valid in their own way.

Technical Article Index <7 8 9> Page Number TO BE CONTINUED


T Attenuator calculator.

Calculates the resistor values, attenuation, 'impedance', reflection coefficient, VSWR and return loss of a T attenuator.

[T attenuator circuit]

1) Enter the system impedance and required attenuation then then press "Calculate" below to obtain the ideal resistor values.

System impedance: | Ohms | Ideal series resistor: | Ohms
Required attenuation: | dB | Ideal shunt resistor: | Ohms
2) Change the Preferred Resistor Values to those available then press " Calculate" below to get the resulting attenuator parameters.
Preferred value of series resistor: | Ohms | Attenuation: | dB
Preferred value of shunt resistor: | Ohms | Input Impedance: | Ohms
 |  | VSWR: |
 |  | Reflection Coefficient: |
 |  | Return Loss: | dB

This calculator uses JavaScript and will function in most modern browsers. For more information see About our calculators.

The calculator uses simple Ohms law calculations, and more comprehensive formulas for Voltage Reflection Coefficient and VSWR which are available at:-

EngRef.pdf

This calculator is provided free by Chemandy Electronics.

Return to Calculator Index


Tank Circuit Resonant Frequency Calculator

The series or parallel resonant frequency of an inductor and a capacitor can be calculated using the following formula.

Where: f = Frequency

C = Capacitance

L = Inductance

Enter the value of the capacitor: | Digits | Mantissa | Frequency: | MHz
Enter the value of the inductor: | Digits | Mantissa |

This calculator uses JavaScript and will function in most modern browsers. For more information see About our calculators.

This calculator is provided free by Chemandy Electronics.

Return to Calculator Index


Technical Article Index

HEMANDY

Technical Articles

This page contains an index of the technical articles on Chemandy Electronics' website.

Accurate Method for Measuring Relative Dielectric Constant of a PCB Using a Vector Network Analyser analyzer and parallel plates.
Single page method, condensed from the five page article below, for those in a hurry. Uses a VNA and has an accompanying calculator.

Building a HF amplifier in a FLEXI-BOX Part 1
Five page article, with photographs, showing the construction of a prototype HF amplifier on a PCB and it's assembly into a FLEXI-BOX.

Linest Function
An explanation of how to use the LINEST function in Excel.

Logest Function
An explanation of how to use the LOGEST function in Excel.

Measuring Characteristic Impedance of PCB tracks using a Vector Network Analyser Part 1
Three page article which expands on a method from Transmission Lines and Networks by Walter C. Johnson, McGraw-Hill 1963 p155 Para 4.7 Measurement of the Characteristics of lines. With an accompanying calculator.

Measuring Relative Dielectric Constant using parallel plate method and Vector Network Analyser Part 1
A five page article that describes how Chemandy Electronics investigated an accurate parallel plate measurement method using a Vector Network Analyser. With an accompanying calculator.

Preferred Resistor Values
A table of preferred resistor values

RF Trap With Attenuators circuit description
A circuit description of this unique FLEXI-BOX project.

Understanding Coaxial RF Transmission Lines by Measurement and Calculation Page 1
A lengthy study of coaxial cables and transmission line theory in simple, logical steps, using a method of measurement and calculation. Hard going and sometimes deviating from classical transmission line theory, this slowly growing article will hopefully shed light on a difficult but intriguing subject.

VHF Pre-amplifier Description
A circuit description of a common base configuration pre-amp that can be used in local or remote powered modes.


VHF Pre-amplifier Description

VHF Amplifier Circuit Description

Introduction

This article describes the circuit of high frequency pre-amplifier working from 88 MHz to 108 MHz in the VHF band, the amplifier uses a single BFS17 transistor in a grounded base configuration. This configuration is used in order to avoid loss of high frequency gain, caused by the Miller effect. An interesting feature of this amplifier is that it can be used as a VHF Pre-Amplifier with DC power available through a local input or as a Remotely Powered VHF Pre-Amplifier with a remote DC source connected via the coaxial cable centre.

Circuit

The schematic diagram of the locally powered version is shown in Figure 1. The input to TR1 emitter is very low impedance ( ≈ Zb/β||R1), and the 50 Ohm input signal is matched to this impedance by L1, C3 and C4. The matching also provides bandpass filtering hence the very narrow frequency response as shown in Figure 2. This filtering is an advantage when the pre-amp is used for FM radio as it functions as a pre-selector.

Figure 1

Figure 2

[Gain and Return Loss graph - S21 and S11 v Frequency]

The input matching circuit provides an input signal to TR1 emitter that has a much lower voltage than the original input voltage and a much higher current. This higher current is passed by TR1 and the collector current is varied by the same amount as the change of emitter current. This change of current across the collector load L2/L3 produces a considerable voltage gain but now at a higher impedance. The high impedance is matched to the 50 Ohm load by C8,C9 and L4. The variable capacitor (C6) tunes the output circuit and is set to give the flattest frequency response. Biasing of TR1 base is via R3 and R2 with decoupling providing by C7. De-coupling capacitors C1, C2 and C5 are added to the + 7.5 Volt supply rail to ensure that the amplifier does not oscillate via the supply. The supply rail voltage is set low, at 7.5 Volts, in order to keep within the voltage ratings of the BFS17 transistor. With a supply current of less than 10 mA, the circuit could powered by batteries. The pre-amplifier gives a gain of approximately 11 dB and a maximum output of power of approximately +4 dBm with 1 dB compression, the output level ripple is less than + 0.6 dB from 88 MHz to 108 MHz. The noise figure of the BFS17 is given as 4.5 dB at 500 MHz typical. A lower noise transistor could be substituted in noise critical applications.

Remotely Powered Version

With one very simple modification, the pre-amplifier can be powered via the centre conductor of the coaxial output connector. The coupling capacitor C8 (1nF) is changed to a zero Ohm link. This leaves L2 unchanged and so it's effect on tuning and output matching also remains unchanged. L2 now just passes DC to capacitors C1, C2 and C5 with any ac present decoupled to ground. The DC on these capacitors still biases TR1 base via R3 and R2 as before with C7 still providing decoupling.

Return to Technical Articles